This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: I cannot translate string on this page: http://www.huanyathai.com/properties/384-%E0%B8%BF0/ As shown in this screenshot: https://cdn.wpml.org/wp-content/uploads/2018/09/2722047-_7_1_.png?x30111

Solution: It was a plugin conflict. I enabled WP_DEBUG mode and found that errors are coming from WPL Pro plugin. I deactivated WPML plugin but errors still throwing and page still showing as blank. Then I deactivated WPL Pro plugin and now blank page issue disappear and page loading it’s content successfully.

This topic contains 14 replies, has 2 voices.

Last updated by pimpornm 1 year, 1 month ago.

Assigned support staff: Noman.

Author Posts
September 7, 2018 at 3:16 am #2713042

pimpornm

I can not translate because there are no words.

September 7, 2018 at 11:39 am #2714335

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Thank you for contacting WPML Support. Can you please try the following steps after taking a backup and let me know how it goes:

1- Go to WPML >> Strings Translation
2- Click the link 'Translate texts in admin screens »' (you'll find it at the bottom of the page)
3) You'll see a page with a large list of text strings. These are all the registered Admin options. Try to find your text here. Take in mind that it can be inside a theme/plugin section. If so, try to click the link to check all its options. If you find your option there, select it marking its checkbox and click Apply button (bottom of the page)
4- Once done you should see the string registered in WPML >> Strings Translation. Then you'll simply need to translate it and mark it as complete.

Here is doc for more details:
https://wpml.org/documentation/getting-started-guide/translating-theme-options/

Thank you

September 7, 2018 at 12:46 pm #2714679

pimpornm

How do I know? What words do I want to translate?

September 7, 2018 at 12:56 pm #2714751

pimpornm

Sorry to send a new picture.How do I know? What words do I want to translate?

September 7, 2018 at 1:36 pm #2714939

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

You can search those words/strings that you want to translate e.g. “Sqw.”. To search easily you can open “Page View Source” and search required strings as in attached screenshots.

Thank you

September 8, 2018 at 9:37 am #2716658

pimpornm

I do as you suggested, but I can not find the words.

September 10, 2018 at 8:48 am #2719239

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

For further debug this issue, please provide temporary access (WP-Admin and FTP Login info) to your site (preferably staging site), so that I can look into your setup and debug the issue.

Your next answer will be private which means only you and I have access to it.

=== Please backup your database and website ===

✙ I would additionally need your permission to de-activate and re-activate Plugins and the Theme, and to change configurations on the site. This is also a reason the backup is really important.

✙ Please add frontend/backend link where I can see the issue.

Thank you

September 11, 2018 at 2:43 am #2722047

pimpornm

There was a problem with the image I attached. I can not solve the problem.

The example I added hidden link

September 11, 2018 at 3:31 pm #2724475

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Thank you for providing login info and screenshots. I am going to work on it and will get back to you with my findings.

September 11, 2018 at 3:51 pm #2724519

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

I have visited the link hidden link that you have provided but it’s showing blank page after header as you can see in attached screenshot.

Also you cPanel login info not working here. Could you please enable error reporting at you site as I need to see the detail of the error log. You can see how to enable debug logging here:
https://wpml.org/documentation/support/debugging-wpml/

To enable it, open your ‘wp-config.php’ file and look for ‘define(‘WP_DEBUG’, false);’. Change it to:

// Enable WP_DEBUG mode
define( 'WP_DEBUG', true );

// Enable Debug logging to the /wp-content/debug.log file
define( 'WP_DEBUG_LOG', true );

// Disable display of errors and warnings 
define( 'WP_DEBUG_DISPLAY', false );
@ini_set( 'display_errors', 0 );

define( 'SCRIPT_DEBUG', true );

This will create debug.log file in your site's wp-content directory. Please send me its contents.

Thank you

September 12, 2018 at 1:24 am #2725497

pimpornm

Can you fix it for me? I do not understand because I just made my first website.

September 12, 2018 at 1:28 am #2725509

pimpornm

I give you a fix on the language does not match the page. And the words I've mentioned are not present and the problem is that the images are blank. It's caused by the wpl pro plugin.

September 12, 2018 at 4:19 pm #2728264

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

I have enabled error reporting in your site to check the cause of the blank page issue. So, that I have added below code in your site’s wp-config.php file:

 // Enable WP_DEBUG mode
define( 'WP_DEBUG', true );

// Enable Debug logging to the /wp-content/debug.log file
define( 'WP_DEBUG_LOG', true );

// Disable display of errors and warnings 
define( 'WP_DEBUG_DISPLAY', false );
@ini_set( 'display_errors', 0 );

// Use dev versions of core JS and CSS files (only needed if you are modifying these core files)
define( 'SCRIPT_DEBUG', true );

After adding above code I examined the debug.log from /wp-content/ folder and found below errors in that file:

[12-Sep-2018 14:57:53 UTC] PHP Notice:  Undefined index: field_308_th in /home/huanyath/public_html/wp-content/plugins/real-estate-listing-realtyna-wpl-pro/libraries/services/sef.php on line 228

[12-Sep-2018 14:57:53 UTC] PHP Notice:  Undefined index: field_308_th in /home/huanyath/public_html/wp-content/plugins/real-estate-listing-realtyna-wpl-pro/libraries/services/sef.php on line 232

[12-Sep-2018 14:57:56 UTC] PHP Fatal error:  Allowed memory size of 268435456 bytes exhausted (tried to allocate 131072 bytes) in /home/huanyath/public_html/wp-content/plugins/real-estate-listing-realtyna-wpl-pro/libraries/dbst_show/general.php on line 318

All errors are related to WPL Pro plugin. I have tried to deactivate WPML plugin but errors still throwing and page still showing as blank. Then I deactivated WPL Pro plugin and now blank page issue disappear and page loading it’s content successfully.

I recommend you to please ask ‘WPL Pro’ plugin author to fix this error.

Thank you

September 13, 2018 at 1:24 am #2729266

pimpornm

Thanks, I'll fix the wpl pro

October 10, 2018 at 11:36 am #2803999

pimpornm

I can not translate because there are no words.

I do as you suggest,
but it does not have words I have to do.