This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 16 replies, has 2 voices.

Last updated by Mihai Apetrei 2 weeks, 6 days ago.

Assigned support staff: Mihai Apetrei.

Author Posts
August 9, 2019 at 9:26 am #4368969

kennethD-8

I am trying to translate the string "24 hour security" in the footer widget. Other strings in the same widget are translated but not this specific string. I have translated other string yesterday but forgot this string. So I tried it today but it didn't work. I have deleted this field and recreated again and translated again but it does not show in French language on front end.

Also regarding the contact form page here: hidden link , I can not translate it too. I need to translate all the fields with "Submit" button text too. I have translated it in the backend but it does not show on frontend.

Note:
I have checked all the requirements and it's all compatible.
There is no caching plugins in the site.
I have searched other issues like this but didn't work for me.
Form in the contact page is Formidble forms.

Regards

August 9, 2019 at 3:54 pm #4371735

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi and thank you for contacting WPML Support!

I will be happy to help you with this.

Can you please try the method below to translate the widget and see if that works?
https://wpml.org/documentation/getting-started-guide/translating-widgets/displaying-different-widgets-for-different-languages/

Regarding the form, can you please try to follow the steps in the documentation below and see if that solves the issue:
https://wpml.org/documentation/plugins-compatibility/how-to-translate-formidable-forms-with-wpml/

If it doesn't, can you please open a new ticket for this issue?

In our forum, we try to keep one issue per ticket.


Continuing with one issue per ticket helps not only supporters to focus on one issue at once, but also enables other users to find solutions to their questions faster.

I will be waiting for your response.

PS: Just a note that I won't be working on the weekend so I will be able to get back to you at the beginning of next week.

If you would prefer to not wait for a ticket response, you can mark this current ticket as resolved and in the process of creating a new ticket, you can select the "Live chat" option (it should be the default method now).

Kind regards,
Mihai Apetrei

August 12, 2019 at 11:22 am #4380337

kennethD-8

Translating the widgets in that way does not work for because theme is just setting the widget in that area but displaying values from customizer theme options. So this does not work.

Rather would you please look into why that specific string is not being displayed though it is translated in the backend.

I will open new ticket regarding form. Additonally, the process that's described there does not work since I am working with the free version of the form.

August 12, 2019 at 4:29 pm #4382351

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Sure, I would be more than happy to take a look!

I would like to request temporary access (wp-admin and FTP) to your site to take a better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of the site files and database before providing us access.

- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box.

The private box looks like this: hidden link

I will be waiting for your response.

Kind regards,
Mihai Apetrei

August 13, 2019 at 2:58 pm #4388963

kennethD-8

Any update on this?

August 13, 2019 at 5:26 pm #4390073

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi.

1. I have noticed that your website’s WP Memory Limit is 40MB. The WP memory limit needs to be increased as the minimum requirement for WPML is 128Mb WP Memory Limit: https://wpml.org/home/minimum-requirements/

❌ Very important: please make a backup of your site (files & database) before following any of the upcoming steps ❌

Please add this to your wp-config.php file to increase WP memory:

/* WP Memory Limit */
define('WP_MEMORY_LIMIT', '256M');
define( 'WP_MAX_MEMORY_LIMIT', '256M' );

Paste it just before:

/* That's all, stop editing! Happy blogging. */

These settings can be limited directly by your hosting provider, so, if that’s the case, I recommend you to contact and ask them to modify them directly. If you can get even higher values It would be great.

Please make sure you have updated the values successfully, You can verify them from WPML >> Support page.

2. We need to increase the MaxInputVars to 50000 - currently, you have them set at 1000.

For this, please try to set this variables in your php.ini:

max_input_vars = 50000;
suhosin.post.max_vars = 50000;
suhosin.request.max_vars = 50000;

You may need to contact your hosting provider to set them.

Please make sure you have updated the values successfully, You can verify them from WPML >> Support page.

After the first 2 steps above have been followed, can you please see if the issue is still happening?

From what I can see, you already translated the "24 hours" custom text from the admin screens so please let me know if after following the steps above anything changes (make sure that you also clear any cache before testing).

3. If nothing changes after following the steps above, please follow the next steps and the string translates:

- disable all plugins except WPML and its add-ons
- check if the issue is happening again
- if it's not, reactivate your plugins one by one, checking every time if the issue shows up again so that you can understand which plugin is causing that issue

I will be waiting for your response.

Kind regards,
Mihai

August 14, 2019 at 12:15 pm #4394743

kennethD-8

I can not make the changes in the live site since it's too risky.

I have made the above mentioned changes in my local environment from increasing the memory limit to deactivating the plugins but I do not get the end result.

August 14, 2019 at 9:35 pm #4397731

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi and thank you for the confirmation.

My guess is that this might be a compatibility issue.

I created a sandbox testing environment on the link below (one-click login):
hidden link

WPML + the WPML add-ons are already installed and I set up the same languages like the ones on the live site, all I would need from you is to install the theme and try to recreate the issue (the idea of a clean sandbox environment is to avoid as much as possible to add any other extra plugins that are not needed, so we would need just the WPML plugins and whatever is needed to recreate the issue - theme and/or plugin).

If the issue is going to happen on our servers, too, that's when I can forward this to our Compatibility team as I think this might be a compatibility issue after all.

Will you please let me know when that's done and what is the result so that we can move forward with this?

Thank you very much for your cooperation.

I will be waiting for your response.

Kind regards,
Mihai

August 20, 2019 at 5:41 pm #4425759

kennethD-8

I have tried duplicating my site on your sandbox but I got issue while migrating database. I am using WP DB Sync plugin to duplicate my site. I have transferred the plugins and themes already. I need to sync the db now but I am getting while syncing db as:

WordPress database error: [Unknown collation: 'utf8mb4_unicode_520_ci']
CREATE TABLE `_mig_rlt_commentmeta` ( `meta_id` bigint(20) unsigned NOT NULL AUTO_INCREMENT, `comment_id` bigint(20) unsigned NOT NULL DEFAULT '0', `meta_key` varchar(255) COLLATE utf8mb4_unicode_520_ci DEFAULT NULL, `meta_value` longtext COLLATE utf8mb4_unicode_520_ci, PRIMARY KEY (`meta_id`), KEY `comment_id` (`comment_id`), KEY `meta_key` (`meta_key`(191)) ) ENGINE=MyISAM DEFAULT CHARSET=utf8mb4 COLLATE=utf8mb4_unicode_520_ci;

So if possible please fix the issue or you can make my another reply private so I can provide the DB file here.

August 21, 2019 at 4:07 pm #4433897

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi.

I may not have been clear enough so sorry for that.

In this sandbox environment, we don't need to duplicate anything from the live site.

What I need you to do is just install the theme that you are using and also any other plugin (but only in the case that's needed to reproduce the issue). That is the process that needs to be followed on a clean sandbox setup - we want to avoid having any other plugins installed that are not needed to reproduce the issue.

I set up WPML once again on this new sandbox and can I ask you to please follow the procedure I explained above on this new one:

hidden link

Please let me know when that's done so that I can take a look.

I will be waiting for your response.

Kind regards,
Mihai

August 22, 2019 at 9:40 am #4438127

kennethD-8

I have setup the site with the themes on our site and setup the footer widget too. But I could not find the strings for translations.

Please do check translation from your side for the widget.

August 23, 2019 at 11:28 am #4446361

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi.

I was able to find those strings by going to WPML > Strings > Translate texts in admin screens (hidden link).

Then I searched for "theme_mods_bellevuex-child" on the page, clicked it, went to "themo_payments_accepted", clicked it, and you can click on each of the elements, from [0] to [8] and mark them for translation.

Then scroll down the page and save the settings. After that you go to WPML > String Translation > you search for the string > translate it > mark it as translated > save it.

So now we know where are those strings coming - admin text strings. However, there is one more thing that we would also need.

Going forward, I will need you to do this on the live site:

We need to increase the MaxInputVars to 24000 - currently, you have them set at 1000.

For this, please try to set this variables in your php.ini:

max_input_vars = 24000;
suhosin.post.max_vars = 24000;
suhosin.request.max_vars = 24000;

You may need to contact your hosting provider to set them.

Please make sure you have updated the values successfully, You can verify them from WPML >> Support page.

Please let me know when that's done.

Kind regards,
Mihai

August 27, 2019 at 3:19 pm #4467927

kennethD-8

I have made the changes. The maxinputvars is increased to 24000. Please verify

August 28, 2019 at 2:41 pm #4475171

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi and thank you for your patience.

Sorry for the late response but yesterday when you wrote I was already out of my shift.

I will spend more time on this and I will get back to you as soon as I have more feedback.

I will leave the ticket assigned to myself for the moment.

Kind regards,
Mihai

August 29, 2019 at 1:32 pm #4481401

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi and thank you for your patience.

This is super weird and my guess is that we are definitely talking about a compatibility issue somewhere in the process or about some extra settings that need to be done for the theme.

I will forward this to the compatibility team so that they can further investigate on this and as soon as I hear from them, I will get back to you.

Kind regards,
Mihai