This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem:
I am trying to translate my Divi site. I expected to see that I could translate the entire page. Instead, I got that I could only translate the page title.
Solution:
Please execute the below MySql query in your site database

ALTER TABLE `wp_icl_strings`  ADD `wrap_tag` VARCHAR(16) NOT NULL  AFTER `location`;

This will add the missing column in the icl_strings table. Once it is done, Update the original page and try editing the translation, this should solve your issue.
Relevant Documentation:
https://wpml.org/forums/topic/text-fields-not-showing-in-the-advanced-editor-only-titles-show/#post-4034789

Tagged: 

This topic contains 7 replies, has 2 voices.

Last updated by Radu 3 months ago.

Assigned support staff: Radu.

Author Posts
July 13, 2019 at 9:43 pm #4204207

Stephanie

I am trying to: Translate my Divi site with woocommerce multilingual

Link to a page where the issue can be seen: hidden link

I expected to see: That I could translate the entire page

Instead, I got: That I could only translate the page Title

Everything is upated
Tried the fix to add new plugin and choose commercial and then make change on default language page
Tables are all there

July 15, 2019 at 6:02 am #4207317

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey Stephanie,

Thank you for reaching out the WPML support!

This is a bit strange. Some other fields should appear on this area (like you mentioned). Is there any chance that you could give me access to the dashboard area so I can have a closer look at this and see why other fields are not appearing? The next reply is set as private so you can safely send me the credentials.

Thanks,
Radu

July 16, 2019 at 5:20 am #4216315

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey Stephanie,

Can you go to Dashboard → WPML → String Translation, please? If you search here for the strings from the homepage (like Same Company, Same People, New Image! or Featured Products), you can find them and add the translation.
For the images, all you have to do is WPML Media Translation plugin. Once you did this, you'll be able to translate the images from the homepage through the Dashboard → WPML → Media Translation. I could see that you have a couple images with text on them and that's why I thought that you'd like to translate them.
Can you give this a try and tell me how it works, please?

Thanks,
Radu

July 16, 2019 at 7:25 am #4217005

Stephanie

Hi Radu, thanks for taking a look. I suppose I could translate everything with the strings, but that is not really very efficient and definitely not when I start having more and more pages with large amounts of text. I think the plugin should work as it is supposed to - there must be something not working correctly.

July 16, 2019 at 7:35 am #4217141

Stephanie

Hi again, I just tried translating the first sentence on the home page... "Welcome....." to Dutch using strings, but it does not show when I switch languages. I also tried to translate the first footer column "about us" and it also does not show.

July 16, 2019 at 1:55 pm #4220743

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey Stephanie,

I found a recent thread where another user had a similar issue and the solution presented here https://wpml.org/forums/topic/text-fields-not-showing-in-the-advanced-editor-only-titles-show/#post-4034789 made everything go back to normal. Can you create a full backup of your website, try to solution from the topic I send to you, and tell me if you can translate the whole content of the page now, please?

Thanks,
Radu

July 16, 2019 at 5:20 pm #4222651

Stephanie

Hi Radu, I tried this solution but I don't think it helped. (see the attached screenshot). After doing this I tried but the situation was the same. I then tried the option of going to the plugins - add new - commercial - look for updates and then changed something on the page and then tried again and MAGIC problem seems to be solved.

So I'm not sure what worked (the plugin fix I had tried earlier to no avail) ... it's a mystery.

Problem is resolved.... thanks for your help.

July 17, 2019 at 8:08 am #4227169

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey Stephanie,

I'm glad to hear that everything is working fine now. I think that the code from the other ticket worked fine. Basically, once that missing table row was created, all you had to do is press the Update button on the page so the strings get registered and appear on the side-by-side translation page.
I'll mark this ticket as resolved now but don't forget that you can open a new ticket anytime you have an issue or need some help with just a quick question.

Wish you a fab one,
Radu