Please make sure to update to WPML to the latest and check our list of Known Issues before reporting

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem:
I don't want to translate events of the Events Calendar plugin.

Solution:
Add the following to your theme's wpml-config.php file:

<custom-types>
    <custom-type translate="0">tribe_events</custom-type>
</custom-types>

Relevant Documentation:
- https://wpml.org/plugin/events-manager/
- https://theeventscalendar.com/knowledgebase/setting-up-the-events-calendar-with-wpml/

Tagged: 

This topic contains 5 replies, has 2 voices.

Last updated by Andrés 3 years, 1 month ago.

Assigned support staff: Andrés.

Author Posts
January 10, 2017 at 3:52 pm #1178726

Henrique

Hello,

I have WPML installed but I don't want to use the duplicate function and only want to have one language for the calendar. The problem is that i cannot uncheck the post types Venues, Organizers and Events from the Multilingual Content Setup, nor from the single event post. How to solve it ? (ps: I have that on all my sites, even with all updates)

January 11, 2017 at 8:57 am #1179226

Andrés
Supporter

Languages: English (English ) Spanish (Español ) French (Français )

Timezone: Europe/Paris (GMT+01:00)

Hello Henrique,

Welcome to WPML support forum.

I understand your concern, however that button is greyed per design and modify could bring some inconsistencies. However, if you want to modify, access to your plugin and check your wpml-config.xml section:

<custom-types>
 <custom-type translate="1">Events</custom-type>
</custom-types>

Copy that part and add/modify the wpml-config.xml file of your theme as follows:

<custom-types>
 <custom-type translate="0">Events</custom-type>
</custom-types>

Documentation:
https://wpml.org/documentation/support/language-configuration-files/

Best regards,
Andrés

January 16, 2017 at 10:37 am #1182791

Henrique

The wpml-config.xml file from my plugin directory don't contain any <custom-types> information and if I copy it in my theme root, adding :

<custom-types>
<custom-type translate="0">Events</custom-type>
</custom-types>

Nothing happen, Events is still checked on "translate" and greyed.

January 16, 2017 at 12:44 pm #1182947

Andrés
Supporter

Languages: English (English ) Spanish (Español ) French (Français )

Timezone: Europe/Paris (GMT+01:00)

After a discussion with our Compatibility team, I see that we have a global wpml-config.xml file for the The events calendar plugin:
hidden link

1. First, could you please check the structure of your wpml-config.xml file, are you using the <wpml-config> tag? Also, you shouldn't use 'tribe_events' instead of Events (it was just an example).

<wpml-config>
  <custom-types>
   <custom-type translate="0">Events</custom-type>
  </custom-types>
</wpml-config>

2. Add the following into your wp-config.php file: it would disable the global wpml-config.xml file:

define('ICL_REMOTE_WPML_CONFIG_DISABLED', true);

Note: be aware that you are overwritten the default behaviour of that plugin and it may cause bugs into the normal flow.

Regards

January 16, 2017 at 1:24 pm #1182989

Henrique

The structure was good but the custom post type name was wrong. You were right with 'tribe_events'. Both

define('ICL_REMOTE_WPML_CONFIG_DISABLED', true);

and

<custom-types>
	<custom-type translate="0">tribe_events</custom-type>
</custom-types>

did the trick, thank you !

January 16, 2017 at 2:28 pm #1183067

Andrés
Supporter

Languages: English (English ) Spanish (Español ) French (Français )

Timezone: Europe/Paris (GMT+01:00)

Great! Have a nice day,
Andrés