This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: I cannot edit translated pages neither View them nor update them. Solution: Deactivating the WPBakery plugin made everything go back to normal in this case. Contacting the plugin authors is the next step to identify what's causing this issue.

This topic contains 20 replies, has 2 voices.

Last updated by deniseB-2 2 months, 2 weeks ago.

Assigned support staff: Radu.

Author Posts
June 21, 2019 at 6:44 pm #4068935

deniseB-2

I am working on a testing platform to solve the problem.

I cannot edit translated pages neither View them nor update them. And I have a problem with the style of the title. It is not vertically aligned anymore in translated pages while it is fine in not translated pages.

I have deactivate WPML plugins and re-activated them. It did not solve the problem.

Maybe there is something that needs to be done with this new WPML version. I have also deactivated only WPML Translation Management and did not fix the problem.

I have upgraded to WordPress 5.2 and upgraded all plugins used.

Please find attached the page A propos (which has its English translated page) and the page Contact in French (which has no English translated page yet).

Please advise.

Thank you.

June 24, 2019 at 5:45 am #4074759

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey Denise,

As I can see, you already have opened a separate ticket about the title alignment and my colleague responded you back on it. In this case, I'm gonna take care of the translation part in this ticket. First of all, can you send me a link to a page where I can see this issue, please? I tried to access hidden link but I can see a blank page. I want to have a look at the two pages and see if I can understand what's going on.

Thanks,
Radu

June 24, 2019 at 10:26 pm #4080019

deniseB-2

Hi Radu,

For your information, I made sure that the minimum requirements to run WPML are met (PHP version 7.0.33 with memory limit 256M).

You can visit this page: hidden link.

Please note that I have modified the data-height of the title to 175px which should be 100px to be vertically aligned until the problem is fixed.

I have deleted a translated page, put it into the trash, deleted it permanently and started all over the translation. It did not fix the problem. I still cannot edit any pages.

I have compared the Settings with another website that I have upgraded without problems.

Could it be Media translation the problem? I realize that Media Translation has been installed in the website with the problem while it has not been installed in the website with no problems.

Both sites use WPML's Translation Editor (not Advanced Translation Editor). In the case of the site with no problem, WPML's Translation Editor is off. I have tried as well to put it off in the site where I have some problems. The problem still persists.

Should I change any settings? Should I reset the settings? Do you recommend deleting WPML cache?

Thank you for your help.

Denise

June 25, 2019 at 2:00 pm #4085253

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey Denise,

Can you give me access to the dashboard area, please? Your description of the problem and all the solutions already attempted are very helpful but I'll need to have a closer look at the settings, trying to figure it out why is this particular website not working (since you said that the same settings are working on a different one). The next is reply is set to be private so you can safely send me the credentials.

Thanks,
Radu

June 26, 2019 at 1:02 pm #4092663

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey Denise,

Thank you for sending me the credentials. While I cannot make the screenshots be private, I can delete them (and I already did that).
Now, I checked the A propos page and I could see that both pages, French and English, are working well. As for the Contact page, since it doesn't have a translation yet, it's only available in French. Can you tell me what is the issue I should see here, please? Or maybe you managed to sort this out in the meantime? I'm asking this because everything looks good and I want to know what's the part that I can help you with.

Thanks,
Radu

June 27, 2019 at 6:47 pm #4102191

deniseB-2

Hi Radu,

The problem is with the pages translated (both versions in French and English).

If I make a text modification, I can save the text block, and then when I click on Update the page, it leads me to a Preview saying that the page does not exist. So, impossible to make any changes.

And also, since the update, the title of the page is not vertically aligned anymore (for pages with French and English versions. You can briefly see the previous alignment when the page is loading. You will also notice that the title is vertically aligned in pages not translated yet.

Thank you for your help.

Denise

July 1, 2019 at 11:37 am #4118529

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey Denise,

I had a look at the title part and it seems that the issue is that the header is going over it. Please copy this CSS:

.main_menu .wpml-ls-item .qode-featured-icon {
    display: none;
}

to the Appearance → Customize → Additional CSS area and tell me if things look better this time.

Regarding the page editing part, can you tell me which page and element from it are you trying to edit, please? This way, I can give it a try too and see why is this happening.

Thanks,
Radu

July 1, 2019 at 12:42 pm #4118987

deniseB-2

Hi Radu,

Thank you so much for the CSS. The title is now vertically centered just as before.

Regarding the page editing, the issue concerns all translated pages but also any other new pages. I can only edit, preview and update a page already existing (in French) that has not been translated.

Please try to add any Lorem ipsum text in a translated page and see what happens when you try to preview the changes and update. (Message: Page does not exist.).

Also try to add a new page with Lorem ipsum text and see what happens (Message: Page does not exist.).

Thank you for your help.

Denise

July 3, 2019 at 7:35 am #4132627

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey Denise,

The website that I'm trying to check is hidden link but you send me the credentials to a different website (hidden link). Can you send me the credentials for the first link so I can try to edit a page and see why is it not working as expected, please?

Thanks,
Radu

July 4, 2019 at 9:29 am #4141889

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey Denise,

Thank you for this explanation. Now everything's clear to me.

Back to the issue, I just edited the French version of this page hidden link by adding one more point at the end of the second paragraph. After that, I edited the English version too hidden link by adding two more points to the same place. The changes I made work fine on both languages and I didn't see any issue, like you described. Can you tell me if I should check a different page where I can see this issue?

Thanks,
Radu

July 4, 2019 at 12:48 pm #4143311

deniseB-2

Hi Radu,

Here are the pages you should check :

hidden link
hidden link

hidden link

Thank you

Denise

July 4, 2019 at 1:12 pm #4143713

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey Denise,

I just had a look at the WordPress configuration and I could see that the memory limit is 40M. Can you increase it to at least 128M (preferably 256M - https://wpml.org/home/minimum-requirements/) and tell me if you still have issue updating the posts, please?
All you have to do is add this line:

define( 'WP_MEMORY_LIMIT', '256M' );

to the wp-config.php file (and other lines with the same code, if any).

Thanks,
Radu

July 10, 2019 at 6:38 pm #4183859

deniseB-2

Hi Radu,

I have increased the memory limit to the wp-config.php file as requested. It did not solve the issue. I still cannot edit the following pages:

hidden link
hidden link

hidden link

Thank you for your help.

Denise

July 11, 2019 at 1:08 pm #4190029

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey Denise,

Can you tell me if you made any change on your website, please? I'm asking this because I was trying to access the dashboard area and I get a message that the password is incorrect. Also, the links that you attached to the last message are not working. All I get is a white page. Can you tell me if I should be checking a different link, please?

Thanks,
Radu

July 11, 2019 at 1:52 pm #4190493

deniseB-2

Hi Radu,

Remember, this is the testing platform (is on Maintenance Mode with no Maintenance Page). You need to access wp-admin in order to view the page from the dashboard.

I have checked the credentials to access wp-admin and they are working just as before. Please refer to the previous private message for credentials.

Thank you for your help.

Denise