This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 11 replies, has 2 voices.

Last updated by Noman 3 months, 3 weeks ago.

Assigned support staff: Noman.

Author Posts
June 25, 2019 at 10:26 am #4083183

jose-antoniod-2

Hi

Since this moorning, I cannot see (and manage) menus at Appearence > Menus
Since I did not install any new plugin today, is it possible the issue is releted to WMPL Plugin?

Thank you

June 25, 2019 at 10:48 am #4083413

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Thank you for contacting WPML Support. Could you please follow below steps and let me know how it goes?

- I have noticed that your website’s WP Memory Limit is 40MB. The WP memory limit needs to be increased, it's different than php memory. PHP memory is fine but WordPress uses 40Mb as default in your site. Minimum requirements for WPML are 128Mb: https://wpml.org/home/minimum-requirements/

Please add this to the top of wp-config.php to increase WP memory:

/* WP Memory Limit */
define('WP_MEMORY_LIMIT', '256M');
define( 'WP_MAX_MEMORY_LIMIT', '256M' );

=== Please backup your database and website ===

- Please upgrade your server’s PHP version to a higher level: https://wpml.org/home/minimum-requirements/

PHP is 5.6.40 which is good, but it's advised is to use more up-to-date version for better performance and stability. You can contact your website hosting company to upgrade this for you.

- You are using an older version of WordPress on your site, please backup your site and update WordPress to it’s latest version 5.2.2.

- Please delete all sort of caches on your site / server cache / plugin cache (WP Super Cache) / CDN cache (if any), clear browser cache and then check the page. I would suggest to disable WP Super Cache plugin temporary.

If still issue persists, please check for a possible theme and plugin conflict. To do that you can switch back to any default theme (e.g. Twenty Seventeen theme), Disable all plugins except WPML and see if this issue goes away with default theme and only WPML activated?

Please let me know if this resolves your issue or you need further assistance with this issue.

Thank you

June 25, 2019 at 11:09 am #4083647

jose-antoniod-2

Excuse me for my poor knowledge about code
I suppose you mean to add this code just after the <?php symbol, don't you?

June 25, 2019 at 11:19 am #4083691

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Yes, correct. You have added in correct location.

June 26, 2019 at 6:56 am #4089529

jose-antoniod-2

Hi again

I did not try to apply your suggestions (upgrade wordpress version, upgrade php...) because there is a reservation system on my web I can not risk it to stop working, so I have to schedule these operations for a bettrer moment. Meanwhile, I found out Main Menu in English (secondary language, cause the main language is Spanish) has "lost" its structure (Spanish: hidden link / English: hidden link)

As long as I don't fix the firts issue I have exposed, do you think I can recover the English Main Menu Structure by using the tool "automatic synchronization of menus" of WMPL??

Thank you

June 26, 2019 at 11:46 am #4092177

jose-antoniod-2

Sorry, I'm trying to get support for this issue 5 years ago... Please

June 26, 2019 at 11:46 am #4092179

jose-antoniod-2

*5 hours, sorry

June 26, 2019 at 3:07 pm #4093491

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Sorry for the delay, you can give it a try please and it should work fine.

Here is doc for menu sync:
https://wpml.org/documentation/getting-started-guide/translating-menus/#option-2-automatic-menus-sync-by-wpml

If still issue persists, please enable error reporting at you site as I need to see the detail of the error log. You can see how to enable debug logging here:
https://wpml.org/documentation/support/debugging-wpml/
https://codex.wordpress.org/Debugging_in_WordPress

To enable it, open your ‘wp-config.php’ file and look for ‘define(‘WP_DEBUG’, false);’. Change it to:

// Enable WP_DEBUG mode
define( 'WP_DEBUG', true );

// Enable Debug logging to the /wp-content/debug.log file
define( 'WP_DEBUG_LOG', true );

// Disable display of errors and warnings 
define( 'WP_DEBUG_DISPLAY', false );
@ini_set( 'display_errors', 0 );

define( 'SCRIPT_DEBUG', true );

After adding the above code please try to reproduce the issue and this will create debug.log file in your site's wp-content directory. Please send me its contents.

Thank you

June 27, 2019 at 7:06 am #4097113

jose-antoniod-2

Hi Noman

Thank you for your help
Here I attached a screenshot of the debug.log
Hope you will be able to help me to try to understand what it means

Thanks again

June 27, 2019 at 8:49 am #4098059

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Thanks for sending me debug.log file contents. These errors are coming from your Triompher theme and not coming from WPML plugins as you can see in error path.

To further debug this issue without affecting your site I can create a test server for you in Cloudways. If it is OK with you, we can migrate your site there to further debug without any risk on your end.

Please let me know your thoughts?

Thank you

June 27, 2019 at 9:46 am #4098621

jose-antoniod-2

Hi Roman

I must apoligize
All this issue was my fault. The error comes, indeed, from functions.php of the theme, as you have told me.

I'm afraid few days ago I added some code at the end of the file but did it in a wrong way, I forgot one "key" sign at the end or maybe all the new code I added was a mistake. I recover the original funtions.php file and everything is working OK. So even in my wordpress version, 2.0, the WPML plugin is working fine!!

Sorry. And thanks for your help!!

June 27, 2019 at 9:51 am #4098727

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Glad to hear your issue is resolved 🙂

Thank you