Skip Navigation

This thread is resolved. Here is a description of the problem and solution.

Problem: I cannot save a specific translation at ATE

Solution:there was some HTML in that specific string for Skype: that was causing the translator to not save

the HTML in question is the one bellow <a href="">Text

removing "" resolves the issue

Text

Relevant Documentation:

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 9 replies, has 2 voices.

Last updated by hilleH 1 year, 4 months ago.

Assigned support staff: Bobby.

Author Posts
June 4, 2019 at 3:25 pm

hilleH

I am trying to: Translate a Contact Field and save it

Link to a page where the issue can be seen: hidden link

I expected to see: That I can finish my Translation.

Instead, I got: It's not saved and so I can not finish my task

June 4, 2019 at 6:40 pm #3954671

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hello,

when you click on "save" , does it turn to green and are you able to redeliver the translation ?

once its redelivered are you still seeing a "gear icon" instead of a "pencil" ?

if it doesnt , are you seeing any warnings or errors ?

June 4, 2019 at 7:44 pm #3954953

hilleH

Hi Bobby

Thank you for you help.

Unfortunately, it doesn't turn green when I click save. And so I cannot redeliver or finish my translation. And yes - I see the gear icon.

No warning errors. It looks like that, when I press save.(see upload)

When I try to redeliver it says ‘ Job not finished
Save and complete the translation of all sentences, then finish the job‘

June 4, 2019 at 9:50 pm #3955503

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

What are your results if you just duplicate the English string into the German, does it turn green ?

If possible i would like to take a closer look but i am not able to access your backend with the above credentials , i get the following page

June 5, 2019 at 6:02 am #3957229

hilleH

Same results.

Can you please try it with hidden link

June 5, 2019 at 6:18 pm #3963367

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

When i go to Pages->Services and click on it to translate i am taken to the classic WPML Translation Editor and it looks to be 100% translated

am i testing the wrong page ?

June 5, 2019 at 7:16 pm #3963607

hilleH

Why is there now the classic Translation Editor? I've never used this editor before. Have you changed that? I'm normally using the ATE.

My described issues I have with the start page.

June 5, 2019 at 10:22 pm #3964355

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

I have not changed any settings on the site , could be that initially the translation of that page was done in the classic WPML Translation Editor and also the page i was looking at was indeed a different page than the one in question.

within WPML->Settings-> Content that was created with WPML's Classic Translation Editor -> it is set to "Use WPML's Classic Translation Editor"

the page in question here opened as expected with Advanced Translation Editor and i was able to see the issue.

i am consulting with our developers at the moment and will update you once i have news

June 6, 2019 at 9:11 pm #3972077

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

After some testing locally i was able to find the issue that was causing this translation problem

there was some HTML in that specific string for Skype: that was causing the translator to not save

the HTML in question is the one bellow
<a href="<a%20href="skype:[ Iris Biermann]?call">">Iris Biermann</a>

removing "<" and ">" resolves the issue

<a href="a%20href="skype:[ Iris Biermann]?call"">Iris Biermann</a>

i have already gone through the Advanced Translation Editor and successfully saved it for you

June 7, 2019 at 6:06 am #3974129

hilleH

My issue is resolved now. Thank you!