This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 9 replies, has 2 voices.

Last updated by Dennis 7 months, 1 week ago.

Assigned support staff: Dennis.

Author Posts
February 28, 2019 at 10:31 am #3254621

sanderv-27

I am trying to: save my settings in backend for the URL format

Link to a page where the issue can be seen: backend needs login

I expected to see: saved

Instead, I got: an error message saying 'not valid'

March 1, 2019 at 7:06 am #3258694

Dennis
Supporter

Languages: English (English )

Timezone: Asia/Manila (GMT+08:00)

Hi,

Welcome to WPML Support forum.

Could you please have a look at the following documentation and verify that your server has the proper configuration to run this option? You will find detailed instructions for DNS and HTTP servers configuration on the link below.

https://wpml.org/2016/04/use-wpml-different-domains-per-language/

Kind regards,
Dennis

March 4, 2019 at 10:10 am #3267958

sanderv-27

Yes I have followed this manual several times over.
As you can see the alternative URL does work (co.uk domain).

However, I cannot change the settings anymore in the back-end of WPML as it keeps saying 'not valid' as you can see in the screenshot.
Could you please mark this topic as ' private' so it is not public?

What does ' not valid ' mean and how can I resolve this? I want to change some of the settings.

March 5, 2019 at 2:03 am #3271093

Dennis
Supporter

Languages: English (English )

Timezone: Asia/Manila (GMT+08:00)

Hi,

Thank you for your reply.

Can you please try to remove the check from the "Validate on save" option and Save again?

Please let me know if the "a different domain per language" option is working now.
- You can test it by switching to the English version of the site using the language selector and check if the English domain is used.

Kind regards,
Dennis

March 5, 2019 at 8:39 am #3272244

sanderv-27

It is working already, and I really do not want to break it on the front end.

I assume the validation does a check that is currently not working.
Simply disabling the check does not seem to be the right answer.
Something is wrong and we need to figure out what.

If I break the language-switcher we have a broken live-website.
It is important this does not happen, so we know what the issue is before we just start ticking boxes.

March 6, 2019 at 1:17 am #3276521

Dennis
Supporter

Languages: English (English )

Timezone: Asia/Manila (GMT+08:00)

Hi,

Thank you for your reply.

You don't have to worry about WPML indicating that it is not valid since it is resolving correctly. If it works, there is no risk about breaking the site.
The validation is just a test. Sometimes, this test returns a false status. This happens with server misconfiguration, or with http auth or, sometimes, with maintenance mode plugins.

Kind regards,
Dennis

March 6, 2019 at 9:03 am #3277640

sanderv-27

OK so how can I check why this test is currently not being validated?

I am not so sure about whether this is not gonna break anything. And as the average response time is 24 hours I don't want to risk it. Could take days for it to be back.

March 6, 2019 at 9:27 am #3277802

Dennis
Supporter

Languages: English (English )

Timezone: Asia/Manila (GMT+08:00)

Hi,

Thank you for your reply.

Sorry for the delayed response as I am working in GMT+8 timezone.

I have consulted this issue to my colleagues before I made a reply to you.

We have clients with similar case as you here:

https://wpml.org/forums/topic/tried-to-configure-a-different-domain-per-language/

https://wpml.org/forums/topic/a-different-domain-per-language-is-not-valid/

Kind regards,
Dennis

March 12, 2019 at 8:32 am #3319291

sanderv-27

This seems like a relative poor solution for a paid plugin.
You have build in something that validated the solution, but if this says not valid you simply disable it? Why would you build it that in the first place?

Can you guarantee that the website still works after I disable that checkbox and save the settings?

March 12, 2019 at 9:50 am #3320365

Dennis
Supporter

Languages: English (English )

Timezone: Asia/Manila (GMT+08:00)

Hi,

Thank you for your reply.

Yes, as long it resolves correctly when you switch languages, there is no risk about breaking the site.

I read all your points and can assure every voice is heard, all suggestion and features request are taken into consideration. I would ask you to direct your suggestion and criticism right to our feature suggestion page at: https://wpml.org/suggest-a-new-feature-for-wpml/. Thank you for helping us improve our product.

Kind regards,
Dennis