Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Author Posts
November 20, 2015 at 8:54 am #750914


I am trying to: Translate my products - but when i tro to acces my translations management i get redirected to a black page

URL of (my) website where problem appears: hidden link and i get redirected to this when i try to edit: hidden link and it says "server error".

I expected to see: My normalt translations management. It all hapend after i updated!

Instead, I got: a blank page, server error and a VERY slow website

November 20, 2015 at 12:09 pm #751136

Mladen Andrejic


1. Can you please first update first WooCommerce Multilingual to the latest 3.7.4 version?

2. Then do the following to resolve permalinks problem :

- Go to WPML > String Translation
- Find the slug permalink (and it's translations)
- Mark that string and under the table click on "Delete String"
- Then go to Settings > Permalinks
- Click on Save (to re save them)
- Now go to WPML > Translation Management > Multilingual Content Setup
- Under Custom Post Type you will see the Products and also slug for main language
- Click on "Use different slugs for Products" and enter the translation
- Hit Save

3. If the problem still persist, please check it when

- All non WPML Plugins are disabled
- Theme is set to default Twenty Fourteen

4. Activate WordPress debug.log and see if there are any errors displayed? Here are the instructions for activating it :

5. You can also check the Chrome built-in JavaScript Console for errors. To open the console go to Menu (Three Bars) > Tools > JavaScript Console

Please paste here any errors that you see in the WordPress debug.log or in JS Console.

// For 500 error - Please create a new ticket, as this is separate issue.


The topic ‘[Closed] I can't acces my translation for products!!’ is closed to new replies.