Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 9 replies, has 2 voices.

Last updated by Bobby 3 years, 7 months ago.

Assigned support staff: Bobby.

Author Posts
March 10, 2017 at 5:04 pm #1227621

enisF

I am trying to:

Change the admin language in backend as default, independently from frontend default language.
If i change in the top bar the wmpl language it will appear that language that i choice in topbar but and if i go after it in the settings user language and trying to change it, it says successfully changed but its the same language still.

For example i have my frontend default language in albanian, and i want if i log in to be in the albanian but with english language, so i can everything make changes for the webpage in albanian front end but working in backend with the english language.

regards

March 10, 2017 at 6:07 pm #1227668

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hello,

Please go to Edit My Profile => and enable Set admin language as editing language.

This will allow you to change the backend editing language (wp-admin) from the top bar as well

March 13, 2017 at 1:15 pm #1228815

enisF

befor i wrote you it was enabled and it is still enabled, and the problem is also.

March 13, 2017 at 4:34 pm #1229089

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hello,

With this setting enabled you should be able to change the language by simply just clicking on the language switcher in your top bar.

This easily changes the backend language , are you not able to do this ?

**Before we proceed I recommend to please take FULL BACKUP of your database and your website.**
I often use the Duplicator plugin for this purpose See: http://wordpress.org/plugins/duplicator/

I would like to request temporary access (wp-admin and FTP) to your site to fix the issue.
(preferably to a test site where the problem has been replicated if possible)

You will find the needed fields for this below the comment area when you log in to leave your next reply.
The information you will enter is private which means only you and I can see and have access to it.

Thank you,
Bobby

March 20, 2017 at 7:58 pm #1235106

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hello,

I was able to replicate the issue on my local install with Albanian set as a language the backend shows mixed results of most strings in Albanian but also strings in English.

If i set your site to Polish or Chinese, for example, i was able to get the whole backend show up in one language.

I have escalated this issue to our higher support for feedback and i will be updating you shortly.

Regarding the second issue you mentioned in your previous reply may i kindly ask you to please open a separate thread addressing that issue since this current thread is being escalated for the issue with the backend language.

This will help us focus on each issue separately and keep everything organized.

Thank you!

March 22, 2017 at 5:04 pm #1237057

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hello,

I escalated this thread to our 2nd tier support and they will take a look at this issue.

You will be notified as soon as new information is available.

Thank you,
Bobby

March 24, 2017 at 5:03 pm #1239098

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hello,

1. On a fresh installation, I can see everything is translated except wpml strings because wpml does not have Albanian translation available.

2. Same results on your site, the only strings not translated to Albanian are WPML , and any other strings generated from 3rd party plugins (ex. Properties in menu) that most likely dont have the sq.mo (Albanian)

In this case you can try and use WPML String Translation to translate these strings (view screenshot)

3. If anything is not translated and the untranslated part is from any plugin, please make sure plugin has Albanian translation available.

4. You can see this by having Albanian enabled without WPML, and then strings that were translated are not anymore.

The only string in your menu that changes when WPML is activated is "Dashboard" and that is because you have used String Translation to translated it from English to Albanian and have set the Albanian translation to "Dashboard" instead of "Pulti".

5. If anything else is not translated please let me know you can add screencast or video regarding the same.

March 27, 2017 at 3:46 pm #1240493

enisF

I have set here to be notifyed also per email when you respond to my question, but no email comes from you when you replay to me.

The problem is not solved, i dont know about what are you talking, and the problem is still there.

If you login in admin in backend. automatically is the dashboard in the albanian language, and the flag in the top bar is albanian flag. So in this part all the admin(menu) is mixed with english and albanian words, if i go in the top bar and change flag to english then the backend will be englisht but i will be in the english part. here we dont have problem.

The problem is if i want to change the language to the albanian dashboard. so i would go in the users and select my user and language, if i change there the language to english, it will just change me to dhe english dashboard with a english flag in the topbar, it will not change all the language in english and stay still in the albanian dashboard.

What i want is whatever a dashboard i choice to be the backend english or albanian i want the language in the backend to be english.

please also notify me in email. i have se here the receive email notification when wmpl suppor posts an answer. but no notification come when you answer.

regards,

March 27, 2017 at 3:46 pm #1240495

enisF

I have set here to be notifyed also per email when you respond to my question, but no email comes from you when you replay to me.

The problem is not solved, i dont know about what are you talking, and the problem is still there.

If you login in admin in backend. automatically is the dashboard in the albanian language, and the flag in the top bar is albanian flag. So in this part all the admin(menu) is mixed with english and albanian words, if i go in the top bar and change flag to english then the backend will be englisht but i will be in the english part. here we dont have problem.

The problem is if i want to change the language to the albanian dashboard. so i would go in the users and select my user and language, if i change there the language to english, it will just change me to dhe english dashboard with a english flag in the topbar, it will not change all the language in english and stay still in the albanian dashboard.

What i want is whatever a dashboard i choice to be the backend english or albanian i want the language in the backend to be english.

please also notify me in email. i have se here the receive email notification when wmpl suppor posts an answer. but no notification come when you answer.
s

regards,

March 27, 2017 at 4:27 pm #1240544

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hello,

Right now your backend is set to be in whichever language you choose from the top bar (ex.if Albanian is chosen then there will be Albanian strings in the backend...Note: You are seeing a mixture of Albanian and English because not all plugins on your site support the Albanian translation.)

"What i want is whatever a dashboard i choice to be the backend english or albanian i want the language in the backend to be english."

===> If you want the dashboard to be ONLY English , then you have to go Your user profile and uncheck the option "Set admin language or language editing." and choose English as your Site Language above.

Then your backend will be in English regardless if you have Albanian or English in the top bar

The topic ‘[Closed] I cant change the admin language in backend as default independently from froned’ is closed to new replies.