This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 16 replies, has 2 voices.

Last updated by Riffaz 6 months, 2 weeks ago.

Assigned support staff: Riffaz.

Author Posts
February 13, 2019 at 3:52 pm #3195129

mariaA-26

I am trying to: change the logo from greek to English

I changed the url in the strings translator but it doesn't work.

I am sending a screenshot

February 13, 2019 at 4:42 pm #3195450

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Thank you for contacting WPML support.

You are missing '/' at the beginning of your translaton.
It should start like this /wp-content/

Let me know how it goes.

Regards,

February 14, 2019 at 10:49 am #3198875

mariaA-26

Thanks for the assistance.
I tried this it doesn't work. What else can I do ?

February 17, 2019 at 6:16 am #3208662

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

I am setting the next reply as private.
Let me know your site login details to check this.

Regards,

February 18, 2019 at 3:31 pm #3213050

mariaA-26

I am running the website in a local server.

February 20, 2019 at 10:23 am #3220793

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

In that case, it's really difficult to troubleshoot it.
Please get back to us when you have a live site.

Regards,

March 14, 2019 at 9:55 am #3342569

mariaA-26

Hi,again,

my site is now live so we can troubleshoot the problem with the logos?

March 17, 2019 at 9:19 am #3363051

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Let us know your site login details.
Next reply is private.

Regards,

March 19, 2019 at 7:29 am #3375983

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

You are using the7 theme.

Could you please follow the below steps to fix the issue:
- From the wp-admin bar at the top, change the language
- Go to theme options -> Branding
- Select the logo accordingly for the other version.

Let me know if this helps.

Regards,

March 19, 2019 at 8:14 am #3376273

mariaA-26

Hi, thank you for your assistance,

I did it but nothing changed.

March 19, 2019 at 11:05 am #3378233

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Try this solution that worked for another user: https://wpml.org/forums/topic/the7-theme-cannot-use-different-logos-in-different-languages/#post-2844896

Let me know how it goes.

Regards,

March 21, 2019 at 8:55 am #3396921

mariaA-26

Hi, in the editor there is no code such as in the solution, I attach the solution and my editor that is empty.

I have t write the code?

March 21, 2019 at 10:31 am #3398165

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Yes, you have to copy that code and paste it to your XML editor.

Regards,

March 27, 2019 at 8:40 am #3468647

mariaA-26

I copied the code but in set strings translation it didn't appear the admin_texts_the7dtchild. I attach the code in order to tell me if I wrote something is wrong.

Thank you

March 27, 2019 at 4:05 pm #3473405

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Now this turns weird.
I even changed your logo image IDs according to the site language hidden link but still it does not work.

Can you please disable all the third party plugins including your security and caching plugin then check the issue?
I do not do that to check because I am not sure if I do that some of your setting may stop work.

If you still see the issue even after this plugins compatibility check, we need to check this in a fresh, minimal installation of the theme and then start troubleshoot to find the cause.

Let me know.

Regards,

The topic ‘[Closed] I can't change the logo between the languages’ is closed to new replies.