This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: Meta Options missing within post editor on Dante theme Solution: Make sure to set all the custom fields (such as sf_thumbnail_link_type) to translate. You can control them on the posts directly.

This topic contains 9 replies, has 2 voices.

Last updated by robertoB-13 3 days, 12 hours ago.

Assigned support staff: Bruno Kos.

Author Posts
October 4, 2019 at 8:03 am

robertoB-13

I am trying to: change heading options and sidebars in translated posts and pages

Link to a page where the issue can be seen: see screenshot p3

I expected to see: hidden link

Instead, I got:

October 4, 2019 at 8:58 am
October 4, 2019 at 10:03 am #4694667

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

This has been escalated to our Compatibility team and may take some debugging time, I'll get back to you as soon as I have any news or questions for you.

Regards,
Bruno Kos

October 7, 2019 at 12:54 pm #4707427

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

Can you check this?
hidden link

It seems like this is up to how these main custom fields are being set. For example, if you set them to "Translate", then they will show up. If you select "Copy", they will copy, "Copy once" will allow you to change them, but will copy their value upon translation creation.

https://wpml.org/documentation/getting-started-guide/translating-custom-fields/

I cannot tell you for 100% which one belongs to which group, but you can do this by testing yourself - you select the preference of each of these custom fields and then you click apply, update the post and then you can see that they should show up (or get hidden), based on what you choose.

You need to do this on one post only and it will be applied globally.

Regards,
Bruno Kos

October 7, 2019 at 1:59 pm #4708013

robertoB-13

Thank you Bruno.
Now I can manage the sidebars again, but I still can't control the Fancy Heading Background Image. As you can see from the screenshots in a is what I see in the italian translation and in b what I see in English. I've searched in the custom fields but it seems is not there the option. I don't know what happened: before last Monday everything was working fine.
R

October 9, 2019 at 9:44 am #4721439

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

I asked our compatibility team what could it be, because I wasn't able to find the custom field either, not sure why isn't it showing up.

Regards,
Bruno Kos

October 10, 2019 at 1:23 pm #4730849

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

Can you check now? I registered a custom field to be translatable, but which is not registered in the options below for some reason.

Regards,
Bruno Kos

October 10, 2019 at 2:12 pm #4731455

robertoB-13

Hi
yeah it's working fine now! Thank you!
But what did you exactly do? I'd like to know it just in order to do it by myself it it happens again.

October 11, 2019 at 7:20 am #4735937

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

If you check here, you will find some XML code:
hidden link

It is about this:
https://wpml.org/documentation/support/language-configuration-files/

For example, the thumbnail link type has the following custom field: sf_thumbnail_link_type (you can see within the image how to get this value - you need to use chrome inspector to see it)

And then inside our XML configuration, in order to make this translatable, you add something like the following:

 <custom-field action="translate">sf_thumbnail_link_type</custom-field>

However, now that all these are in place, they will be applied globally and you should not worry about it anymore (unless theme developer ads new ones as they update these options).

Regards,
Bruno Kos

October 11, 2019 at 7:38 am #4736055

robertoB-13

Thank you Bruno. Have a good weekend
Roberto

October 11, 2019 at 7:41 am #4736131

robertoB-13

It took 10 days to solve the problem, anyway my issue is resolved now. Thank you!