This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 7 replies, has 2 voices.

Last updated by Noman 2 months, 3 weeks ago.

Assigned support staff: Noman.

Author Posts
July 26, 2019 at 7:19 pm #4291477

kevinR-30

Tell us what you are trying to do?: I am trying to setup WPML on my WordPress. I had initially had it already setup, but then I had to switch the theme layout of the site. Just tried reactivating it on the new layout, and I cant seem to get through the setup process.

Is there any documentation that you are following? Yes, I have followed the setup documentation, it just has a white screen when I try to go form Step 3 to Step 4

Is there a similar example that we can see? I will attach screen shots, I cant get past the setup.

What is the link to your site? originalgashole.com

July 26, 2019 at 8:25 pm #4291735

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Thank you for contacting WPML Support.

1. It seems you have just installed WPML plugins and configuring WPML first time on this site and do not have any translated data yet. So you can fix this issue by removing WPML and all its data completely from database.

=== Please backup your database and website ===

To do so:
- Please go to WPML >> Support >> Troubleshooting (the link is at the bottom of the support page). >> There, click on “Reset and deactivate WPML” >> then Delete the plugin.

2. Please enable error reporting at your site as I need to see the detail of the error log. You can see how to enable debug logging here:
https://wpml.org/documentation/support/debugging-wpml/
https://codex.wordpress.org/Debugging_in_WordPress

If still issue persists, Please add the debug report in the Debug Information box. I have also enabled debug info box for your next reply: https://wpml.org/faq/provide-debug-information-faster-support/

Thank you

July 26, 2019 at 10:44 pm #4291987

kevinR-30

I have reset, then deleted, then re added and activate the plugins, and the same problem is continuing. Hopefully whatever is above can help. Thank you

July 27, 2019 at 3:18 pm #4293797

kevinR-30

I did have it initially setup before I had to change the layout and I did have a few different languages translated for some content.

July 27, 2019 at 3:43 pm #4293899

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Thanks for the debug info, most of the details looks fine. It can be some sort of conflict with the new theme or other plugins that you may have added. To take a closer look on this issue and enable error reporting, please provide temporary access (WP-Admin and FTP Login info) to your site, so that I can look into your setup and debug the issue.

Your next answer will be private which means only you and I have access to it.

✙ I would additionally need your permission to de-activate and re-activate Plugins and the Theme, and to change configurations on the site. This is also a reason the backup is really important.

Thank you

July 27, 2019 at 4:13 pm #4293923

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

ok thanks for the details and login. I am going to work on this further and get back to you soon. In the meantime can you please confirm you have taken full site backup too?

July 27, 2019 at 4:15 pm #4293925

kevinR-30

Yes I have a site Back Up, thank you!

July 27, 2019 at 4:24 pm #4293929

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

I activated 2019 theme temporarily >> deleted cache in your site >> then run the setup of WPML >> and I was able to finish the setup. So this problem appears to be solved, please check.

I have again changed your site's theme as it was (Motors theme).

Thank you and have a great weekend.