This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 5 replies, has 2 voices.

Last updated by eleanorD-2 4 months, 2 weeks ago.

Assigned support staff: Riffaz.

Author Posts
May 28, 2019 at 11:26 am

eleanorD-2

I am trying to run through the basic setup. I've already added my site key... and I selected English as my main language and then Spanish as the only other translation language.

However - after I select Spanish and then click the blue "Next" button. the page just refreshes and doesn't let me proceed to "3. Language Switcher"

Is this something you can please help with?

Thanks in advance

May 28, 2019 at 11:49 am #3906417

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Thank you for contacting WPML support.

Normally this is caused by SG optimzer plugin.
Anyhow, please disable all the plugins and check the issue.

Also, your WP Memory is 40Mb which is not enough.
Please increase it to 768Mb which is the amount your hosting package allows maximum.

Add this near the top of wp-config.php file (after the php opening tag) to increase WP memory:

/** Memory Limit */
define('WP_MEMORY_LIMIT', '768M');

And,
Console Errors
In your chrome browser Press Ctrl + Shift + J (Windows / Linux) or Cmd + Opt + J (Mac) before you go to this step.
Check if you see any red errors here : hidden link and let me know.

Let me know how it goes.

Regards,
Riffaz.

May 28, 2019 at 12:23 pm #3906815

eleanorD-2

Thanks. Those steps didn't seem to work (my host changed the memory for me via cPanel as I kept crashing the site playing with wp-config). However - I tried adding a third language (French) and it let me proceed anyway. So I'll just delete out the superfluous language later on.
Cheers for your help.

May 28, 2019 at 12:24 pm #3906821

eleanorD-2

My issue is resolved now. Thank you!

May 28, 2019 at 12:25 pm #3906827

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

That's a good hack.
Glad it works now.

Please close this ticket and create a new ticket if you have any other issues.

Regards,

May 31, 2019 at 7:50 am #3928303

eleanorD-2

Thanks again for your help. Ticket now marked as resolved.