This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 9 replies, has 3 voices.

Last updated by kamilK-6 1 year, 5 months ago.

Assigned support staff: Bigul.

Author Posts
April 22, 2018 at 12:10 pm #1750425

yannisZ

Tell us what you are trying to do? To translate "WOOF-Product Filter" title. See attached file.

Is there any documentation that you are following? I was trying to locate the string from string translation menu but without success.

Is there a similar example that we can see?

What is the link to your site? hidden link

April 24, 2018 at 12:55 pm #1789442

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Welcome to the WPML support forum. I will do my best to help you to resolve these issues. Sorry for the delay in answering.

In some cases, it is possible that those strings have been recognized but not associated yet to the String Translation panel for the translation. Please try the following steps after a backup and let me know your feedback.

1) Please make sure the *MaxInputVars* of PHP settings is *10000*. If not, please check the following article for more details or contact your system admin/hosting provider for this purpose.

hidden link

2) Visit WPML>>String Translation
3) Click on the blue link at the bottom of the page: "Translate texts in admin screens »"
4) Look for an option similar to "WOOF_product_Filter", or something like that. Here you should find all strings associated with your theme options.
5) Check the checkbox for your strings of interest.
6) Click on the button "Apply"(at the bottom of the page)
7) Now, all your selected strings should appear in the String Translation panel and you can translate those strings

Please check the following documentation for more details.

https://wpml.org/documentation/getting-started-guide/translating-theme-options/

https://wpml.org/documentation/getting-started-guide/string-translation/#admin_texts

To help you faster, I've enabled debug information for this support ticket. Please see this link for how to get this information from your site and give it to us: http://wpml.org/faq/provide-debug-information-faster-support/

--
Thanks!

Bigul

April 24, 2018 at 4:41 pm #1794094

yannisZ

Hi Bigul and thank you for your reply,

I confirm that *MaxInputVars* of PHP settings is *10000*.
Also I tried the steps 2 to 7 and the string appeared in the search, see attached file, I changed them but still they not appear translated.

What else can I try?
Yannis

April 25, 2018 at 1:09 pm #1810239

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Yannis,

Thank you for the updates. Please fill the private details fields after a full site backup. I would like to access admin area of your site for further checking. Please check the following links for more details about our private information sharing policies.

hidden link

https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

Please let me know how you are managing the *WOOF-Product Filter* options in the backend for a better understanding.

Maybe you are facing this issue because of compatibility issues. So to make sure if possible, please do the following steps.

a) Backup your site first
b) Switch for a moment to a WordPress default theme like 2017
c) Deactivate all the plugins that are not related to WPML
d) If the issue is gone, activate one by one to see with which one there is an interaction issue

--
Thanks!

Bigul

April 27, 2018 at 12:21 pm #1859492

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Yannis,

Thank you for the login information. I went through the settings, it looks like a compatibility issue and requires further checking. So please allow me to make a duplicator copy of your site using Duplicator plugin(https://wordpress.org/plugins/duplicator/) for debugging the issue on my local server.

--
Thanks!

Bigul

April 27, 2018 at 12:46 pm #1859804

yannisZ

I have already backup the site and of course you can go on with a duplicator copy for further checking.

Thank you for your help.
Yannis

April 27, 2018 at 5:55 pm #1866717

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Yannis,

Thank you for the permission. I made a duplicator copy of your site now. Will debug it further and get back to you soon. Please wait.

--
Thanks!

Bigul

May 1, 2018 at 1:00 pm #1912691

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Yannis,

I have traced the reason for the issue. It is happening because of the code *WOOF - WooCommerce Products Filter* is using for listing the taxonomy label is not compatible with WPML. It works for me(on local copies) after I made the following changes. Please try it after a site backup and let me know your feedback.

1) Visit *wp-content/plugins/woocommerce-products-filter/classes* folder
2) Open *helper.php* file for edit
3) Add the following code after line 273

$string = apply_filters('wpml_translate_single_string', $WOOF->settings['custom_tax_label'][$taxonomy_info->name], 'admin_texts_woof_settings', '[woof_settings][custom_tax_label]'.$taxonomy_info->name ); 

4) Save the changes

--
Thanks!

Bigul

May 1, 2018 at 4:36 pm #1915549

yannisZ

It works great! Thank you Bigul one more time for your help!

All the best,
Yannis

July 12, 2019 at 9:05 am #4196749

kamilK-6

Hi Bigul,

I used your code and I can already translate custom_tax_label.

Unfortunately, after adding your code, the filter button disappeared.

How can we solve this?

Regards