This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: Invalid site key for the current site.

Solution: - Back up your site first before making any change, this is for security reasons. - Go to Plugins -> Add new -> Commercial tab -> Click on 'Register WPML' button -> Uncheck 'Keep wpml.org up-to-date about which theme and plugins I use' option -> Insert the key and register the plugin.

Relevant Documentation:

0% of people find this useful.

This topic contains 4 replies, has 3 voices.

Last updated by nicod-4 1 year, 6 months ago.

Assigned support staff: Carlos Rojas.

Author Posts
April 12, 2018 at 6:32 pm

lorenzoV-6

I am trying to: register

Link to a page where the issue can be seen: hidden link

I expected to see: got registered

Instead, I got: Invalid site key for the current site.

I have the problem too that the lang switcher in the home goes to the http instead of https

April 12, 2018 at 10:13 pm #1615103

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hello,
Thank you for contacting WPML support.

I would like to ask you to follow this steps in order to isolate the cause of the issue:
- Back up your site first before making any change, this is for security reasons.
- Go to Plugins -> Add new -> Commercial tab -> Click on 'Register WPML' button -> Uncheck 'Keep wpml.org up-to-date about which theme and plugins I use' option -> Insert the key and register the plugin.

Could you tell me the result of this steps?

Kind regards,
Carlos

April 12, 2018 at 11:59 pm #1615773

lorenzoV-6

thx!!

April 13, 2018 at 2:53 pm #1624173

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi,

I'm glad to hear that the issue is solved 🙂

Please don't hesitate to contact us if you need our help in the future with WPML. We will be more than happy to help.
Best regards,
Carlos

April 4, 2019 at 1:47 pm #3535495

nicod-4

Hi,

I have the same issue, but i'm using a multisite setup. I can't find where to activate the plugin. WPML is not nework activated. So if i go to plugins on a site where i've enabled WPML there is no "add new" menu-item to click on.

Is there an other way to activate the plugin?