This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: When I click on the + icon to create the page in the new language, instead of the 2 columns layout where I can just insert the translation based on the content of my original page (what I saw on every tutorial I watched) it opens up a page where I have to create the page from scratch (no content or formatting from the original language page is taken).

Solution: Can you please take a look at the solution in the ticket link below? I think you are experiencing the same thing: https://wpml.org/forums/topic/wants-to-make-a-different-page-instead-translating/#post-4109649

Also, here is some helpful documentation for that, too: https://wpml.org/documentation/translating-your-contents/using-different-translation-editors-for-different-pages/

Practically, you would first need to go to the original language of the post/page and on the right side, you should enable "Use WPML's Translation Editor".

This topic contains 2 replies, has 2 voices.

Last updated by ozlemY 3 months, 3 weeks ago.

Assigned support staff: Mihai Apetrei.

Author Posts
July 1, 2019 at 9:01 am #4116743

ozlemY

I just purchased a Multilingual CMS license for the website I'm building with Elementor + Unit Five theme from Progression Studios (which is WMPL compatible).

I have installed all the plugins and followed the wizard's instruction and I am ready to translate my pages.

THE PROBLEM: when I click on the + icon to create the page in the new language, instead of the 2 columns layout where I can just insert the translation based on the content of my original page (what I saw on every tutorial I watched) it opens up a page where I have to create the page from scratch (no content or formatting from the original language page is taken).

Any idea why this is happening? I attach screenshots for better clarity.

July 1, 2019 at 9:11 am #4116851

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi and thank you for contacting WPML Support!

I will be happy to help you with this.

Can you please take a look at the solution in the ticket link below? I think you are experiencing the same thing:
https://wpml.org/forums/topic/wants-to-make-a-different-page-instead-translating/#post-4109649

Also, here is some helpful documentation for that, too:
https://wpml.org/documentation/translating-your-contents/using-different-translation-editors-for-different-pages/

Practically, you would first need to go to the original language of the post/page and on the right side, you should enable "Use WPML's Translation Editor".

Please let me know if this solved your issue or if you still need help.

I will be waiting for your response.

Kind regards,
Mihai Apetrei

July 1, 2019 at 9:45 am #4117405

ozlemY

My issue is resolved now. Thank you!