This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: The client is using the Flatsome theme and he can't see the language switcher at the top section of the site

Solution: Follow the documentation here in order to create the language switcher: https://wpml.org/documentation/getting-started-guide/language-setup/language-switcher-options

This topic contains 8 replies, has 2 voices.

Last updated by bouhafsia 4 months, 3 weeks ago.

Assigned support staff: Mihai Apetrei.

Author Posts
May 27, 2019 at 9:36 pm #3901109

bouhafsia

iam using fltasome template , and i can't see language selector in my website ?

there is some missing steps , i was trying to translate evrything in my website but i am lost , some contentns are trnsalted , others now , menu not translated ....and so on , i tryied to see some tutorials but

Is there a similar example that we can see?

What is the link to your site?
hidden link

May 28, 2019 at 10:37 am #3905729

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi and thank you for contacting WPML Support!

I will be happy to help you with this.

This should be the normal process to enable the language switcher:
https://wpml.org/documentation/getting-started-guide/language-setup/language-switcher-options/

If that doesn't work, I would like to request temporary access (wp-admin and FTP) to your site to take a better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of the site files and database before providing us access.

- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box.

The private box looks like this: hidden link

In order to be able to help you faster, can you also please paste your WPML Debug information in the Debug information field?
http://wpml.org/faq/provide-debug-information-faster-support/

I will be waiting for your response.

Kind regards,
Mihai Apetrei

May 28, 2019 at 5:25 pm #3909033

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hello.

I have created the language switcher in the settings.

I am attaching 2 screenshots, too.

Please let me know if this solved your issue or if you still need help.

I will be waiting for your response. 🙂

Kind regards,
Mihai

May 28, 2019 at 6:23 pm #3909349

bouhafsia

That's great man , i move it to the top , i need it more discreet , but now i can't see the flag for the second language , i mean whene mouse hover it should show 2 flag to switch between the 2 sites . i will try to translat all strings and try again ?

May 28, 2019 at 8:59 pm #3910099

bouhafsia

i think i succed to pu the selector with 2 languages , but sill have a problem , why i have 404 page not found for the home page ?

May 28, 2019 at 9:01 pm #3910111

bouhafsia

this is should be the home page for my new language but i don't get anything ?

May 29, 2019 at 11:51 am #3915161

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi.

I think it looks perfect where you have put it right now. It is visible and discreet at the same time. Great job with that.

From my understanding, there is also a different issue happening.

In our forum, we try to keep one issue per ticket.


Continuing with one issue per ticket helps not only supporters to focus on one issue at once, but also enables other users to find solutions to their questions faster.

As the original issue is resolved may I kindly ask you to please mark this ticket as resolved and open a new ticket for the additional issue?

Thank you for your understanding.

Kind regards,
Mihai

May 29, 2019 at 11:56 am #3915195

bouhafsia

Great Job , sir , thank you for your help , i will try to open the new ticket later.

May 29, 2019 at 11:58 am #3915201

bouhafsia

My issue is resolved now. Thank you!