This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: #1 Languages flags are not showing although languages are enabled #2 How to translate visual composer

Solution: #1 Just enabling the languages will not show the flags on the pages, you will need to translate the page completely too, so if the flag is not showing on some pages, make sure to check if the page is translatable.

Relevant Documentation: https://wpml.org/documentation/translating-your-contents/page-builders/

Author Posts
May 11, 2018 at 4:49 pm #2092595

georgeT-17

I am trying to add two languages but i just can see one language option after adding. and how to translate every parts of the site, i mean if i go to visual composer and try to translate all parts of my site i can't do that. I just see few features of visual composer that i can translate, not all the features. please help me thanks.

May 14, 2018 at 9:30 am #2113964

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Thank you for contacting WPML support. I'd be happy to assist you further on this issue.

Until you translate your content to the secondary languages the flags will not show up, the translation needs to be complete in order to be translatable.

Regarding translating visual composer items, please follow the steps as mentioned in the documentation and let me know if this helps. https://wpml.org/documentation/translating-your-contents/page-builders/

Look forward to your reply.

Thanks