This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 9 replies, has 2 voices.

Last updated by Raja Mohammed 2 months ago.

Assigned support staff: Raja Mohammed.

Author Posts
July 30, 2019 at 4:12 pm

bobbyA

I am trying to: set a static homepage but it says "your homepage doesn't exist or the translation isn't published"

Link to a page where the issue can be seen: Nauticahans.com

I expected to see: hidden link

Instead, I got: an error page

July 31, 2019 at 6:32 am #4311785

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi there,

I am unable to login to your site with the provided details.
Could you please provide me with the working credentials, I have enabled private fields for you to securely share the details.

The message seems like the page translation hidden link is not 100% complete in the translation editor. Please complete the translation if not already done and check if that helps.

Kind regards
Raja

July 31, 2019 at 6:09 pm
August 1, 2019 at 3:56 am #4318615

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

I have removed your previous reply since the details are publicly exposed. For security reasons Please remove the access from your site and create a new one.

You will find the private fields below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

If you don't see the form below, pelase don't add your credentials as they will be publicly exposed: hidden link

regards
Raja

August 1, 2019 at 4:14 pm
August 2, 2019 at 12:58 pm #4330115

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

I am still not able to login with the supplied credentials 🙁 can you please update your previous reply with working credentials.

If your theme supports a header widget you can add the language switcher to that if you prefer not to display them in the menu.

Please refer: https://wpml.org/documentation/getting-started-guide/language-setup/language-switcher-options/

In case if you want that in a custom location, I would suggest adding the below PHP code in the desired location in your theme file

do_action('wpml_add_language_selector');

– outputs the language switcher based on the options set in the Custom Language Switchers section.

I hope this helps you better, let me know if you need further assistance.

Regard
Raja

August 4, 2019 at 8:49 am #4335875

bobbyA

I can't figure it out myself, I edited the previous creditentials

August 5, 2019 at 9:51 am #4339459

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

I am still unable to login, I have checked with one of the colleagues he also got the same error 'Oops, that's not the right password. Please try again! '
Could you please check whether the user is active on your site?

August 5, 2019 at 10:25 am #4339765

bobbyA

I edited the private message and send some screenshots

August 6, 2019 at 9:52 am
August 6, 2019 at 10:04 am
August 10, 2019 at 2:40 pm #4375741

bobbyA

I migrated the site, I would like assistance with the language switcher widget

August 13, 2019 at 10:50 am #4387167

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi, I have not forgotten about this. I am looking into your issue. I will update you once I have something to share with you.

Regards
Raja

August 13, 2019 at 11:21 am #4387375

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

I am unable to reproduce the static home page issue in the clone site.

It seems you have created the home page with Dutch as default language but made the English as the default language of the site, Maybe the site default language has been changed recently can you please confirm on this?

In any case, I would suggest updating the original content in your case the Dutch home page is the original content and the English home page is a translation. Please update the dutch home page with some minor modification and update the English translation as well. I hope this will help you resolve the layout issue.

Let me know if you need further assistance.

Kind regards
Raja