This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem:

Pagebuilder's (VC) agenda block content does not show up in translation editor.

Solution:

Add the following code snippet to your WPML > Settings > Custom XML Configuration

<wpml-config>
  <shortcodes>
    <shortcode>
      <tag>om_agenda</tag>
    </shortcode>
    <shortcode>
      <tag>om_agenda_day</tag>
      <attributes>
        <attribute>title</attribute>
        <attribute>date</attribute>
      </attributes>
    </shortcode>
    <shortcode>
      <tag>om_agenda_item</tag>
      <attributes>
        <attribute>time</attribute>
        <attribute>title</attribute>
      </attributes>
    </shortcode>
  </shortcodes>
</wpml-config>

-edit the page on the original language.
-make a small change on any of the content blocks. click 'Update.
-undo the small change. click 'Update'
-translate the page to secondary languages.

Relevant Documentation:

https://wpml.org/documentation/support/language-configuration-files/#page-builder-content

This topic contains 6 replies, has 2 voices.

Last updated by thomasA-49 4 months, 3 weeks ago.

Assigned support staff: Dennis.

Author Posts
May 12, 2019 at 1:27 pm #3793029

thomasA-49

I am trying to: translate hidden link

Link to a page where the issue can be seen: hidden link

I expected to see: the options to translate the different strings when I press the french translation button

Instead, I got: all i get is the translation of the schedule string to agenda

May 13, 2019 at 3:29 am #3794665

Dennis
Supporter

Languages: English (English )

Timezone: Asia/Manila (GMT+08:00)

Hi,

Welcome to WPML Support forum.

It seems that your using Gravity Forms for displaying the form on your page. If that's the case, you need to install WPML's Gravity Forms Multilingual plugin which you can download from your wpml.org account downloads page.

For more information on how to translate Gravity Forms using WPML, please check this documentation below:

https://wpml.org/documentation/related-projects/gravity-forms-multilingual/

Hope this helps.

Kind regards,
Dennis

May 16, 2019 at 4:29 am #3821917

thomasA-49

Hi Dennis,

Its actually not the gravity form thats giving me the problem. Once you fill in the form you will see the agenda. It is this agenda that is built using WPBakery that is causing the problem.

May 16, 2019 at 8:47 am #3823355

Dennis
Supporter

Languages: English (English )

Timezone: Asia/Manila (GMT+08:00)

Hi,

Thank you for your reply. I think I understand it now.

I would like to request temporary access (/wp-admin and FTP) to your site to take a better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. Your next reply will be set to private.

Maybe I'll need to replicate your site locally to continue debugging and escalate if necessary. For this I’ll need to temporarily install a plugin called “Duplicator” on your site. This will allow me to create a copy of your site and your content. Once the problem is resolved I will delete the local site. Please confirm if this okay with you.

Our Debugging Procedures
I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to BACKUP the site before providing us access.

Privacy and Security Policy
We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

Thank you.

Kind regards,
Dennis

May 17, 2019 at 2:12 am #3830259

Dennis
Supporter

Languages: English (English )

Timezone: Asia/Manila (GMT+08:00)

Hi,

Thank your for providing us with the access details and I apologize for the late reply as I work in GMT+8 timezone.

I tried to access you admin page using the provided credentials but it does not work on my end. Could you please check and send me again the updated credentials?

Thank you.

Kind regards,
Dennis

May 20, 2019 at 4:20 am #3843585

Dennis
Supporter

Languages: English (English )

Timezone: Asia/Manila (GMT+08:00)

Hi,

Please add the following code snippet to your WPML > Settings > Custom XML Configuration on your live site? I have updated the test site so you can also check it out.

<wpml-config>
  <shortcodes>
    <shortcode>
      <tag>om_agenda</tag>
    </shortcode>
    <shortcode>
      <tag>om_agenda_day</tag>
      <attributes>
        <attribute>title</attribute>
        <attribute>date</attribute>
      </attributes>
    </shortcode>
    <shortcode>
      <tag>om_agenda_item</tag>
      <attributes>
        <attribute>time</attribute>
        <attribute>title</attribute>
      </attributes>
    </shortcode>
  </shortcodes>
</wpml-config>

-edit the page on the original language.
-make a small change on any of the content blocks. click 'Update.
-undo the small change. click 'Update'
-translate the page to secondary languages.

Documentation: https://wpml.org/documentation/support/language-configuration-files/#page-builder-content

Please let me know how it goes.

Kind regards,
Dennis

May 20, 2019 at 6:46 am #3843985

thomasA-49

My issue is resolved now. Thank you!