This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: I want to translate the word client, quote, task in portfolio field. It is a custom field from ACF.

Solution: - Install ACF Multilingual. - Follow this tutorial.

Relevant Documentation: https://wpml.org/documentation/related-projects/translate-sites-built-with-acf/

This topic contains 13 replies, has 2 voices.

Last updated by zedC 1 year, 5 months ago.

Assigned support staff: Andrés.

Author Posts
May 18, 2018 at 6:54 am #2186497

zedC

i want to translate the word client, quote,task in portfolio field.
i try to edit all the word, but it no show the translation,can you help me?

for example my website is hidden link

May 21, 2018 at 6:39 am #2198985

Andrés
Supporter

Languages: English (English ) Spanish (Español ) French (Français )

Timezone: Europe/Paris (GMT+02:00)

Hello there,

Welcome to WPML support forum.

1. Could you please tell me if you are able to edit "client, quote, task" strings from your theme options? If yes, how do you do it? Could you add some screenshots?

2. Provided that you have the "WPML String Translation" AddOn installed please follow these steps:
- Go under "WPML -> Theme and plugins localization".
- Make sure that "Translate themes and plugins using WPML's String Translation only (don't load .mo files)" is active.
- Scroll down to "Strings in the theme" and click on "Scan the theme for strings".
- Once you followed the above steps go under "WPML -> String Translation". All strings available for translation should display in the table you see there.

Do you see them? If yes, all you need to do is click on "translations" next to each string you want to translate and enter + save your translations.

Documentation:
https://wpml.org/documentation/getting-started-guide/string-translation/

3. To help you faster, I've enabled debug information for this support ticket. Please see this link for how to get this information from your site and give it to us:
http://wpml.org/faq/provide-debug-information-faster-support/

Best regards,
Andrés

May 21, 2018 at 6:51 am #2198992

zedC

i going to change all the translation into Chinese , they have show the string translation but i have edited and it is not make translation into Chinese. i know that i am using custom field to add on the portfolio field.

May 21, 2018 at 6:54 am #2198994

Andrés
Supporter

Languages: English (English ) Spanish (Español ) French (Français )

Timezone: Europe/Paris (GMT+02:00)

Perfect, let me know once you do that or when you perform the previous action so I can better understand your situation.

May 21, 2018 at 7:07 am #2199121

zedC

the first picture is to open a portfolios field, and then i can go to any portfolio post to write content to the client or task. after that i go to string translation, but the translation of clients does not found in the string translation

May 21, 2018 at 7:11 am #2199126

Andrés
Supporter

Languages: English (English ) Spanish (Español ) French (Français )

Timezone: Europe/Paris (GMT+02:00)

1. It seems that you are using ACF for making those custom fields. Could you please install our ACF Multilingual and follow this tutorial?
https://wpml.org/documentation/related-projects/translate-sites-built-with-acf/

2. Could you please increase your Memory Limit to 256M as it is lower than your WP Memory Limit which is incorrect and can lead to errors?
Your current values are:
- MemoryLimit 128M
- WP Memory Limit 256M

These settings can be limited directly by your hosting provider, so I recommend you to contact and ask them to modify them directly. If you can get even higher values It would be great.

https://wpml.org/home/minimum-requirements/
Note: WPML needs a minimum WP Memory limit of 128M to work only under a minimal environment, it means, with a default theme and not other plugins installed.

May 21, 2018 at 7:35 am #2199157

zedC

hello, i changed it in the wp-config file , and i am using MemoryLimit 256M and WP Memory Limit 256M already.

i am also try to change the question1 you mention but nothing happen. can you teach me?

May 21, 2018 at 7:36 am #2199159

Andrés
Supporter

Languages: English (English ) Spanish (Español ) French (Français )

Timezone: Europe/Paris (GMT+02:00)

I would like to request temporary access (wp-admin and FTP) to your test site to take a better look at the issue. Could you please indicate me how to replicate this behaviour?

You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Maybe I'll need to replicate your site locally. For this, I’ll need to temporarily install a plugin called “Duplicator” on your site. This will allow me to create a copy of your site and your content. Once the problem is resolved I will delete the local site. Let me know if this is ok for you.

*Important: Be sure to backup your site and database first before you proceed!
You can use a plugin for this if you like. You can use the Duplicator plugin for this purpose.
See: http://wordpress.org/plugins/duplicator/

If you don't see the form below, pelase don't add your credentials as they will be publicly exposed:
hidden link

Privacy and Security when Providing Debug Information for Support:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

May 21, 2018 at 7:46 am #2199166

Andrés
Supporter

Languages: English (English ) Spanish (Español ) French (Français )

Timezone: Europe/Paris (GMT+02:00)

Thanks for your credentials but I see that you haven't install our ACF Multilingual as I mentioned in my previous post.

Could you please install it and follow this tutorial?
https://wpml.org/documentation/related-projects/translate-sites-built-with-acf/

May 21, 2018 at 8:01 am #2199218

zedC

i am finished install.

May 21, 2018 at 8:15 am #2199498

Andrés
Supporter

Languages: English (English ) Spanish (Español ) French (Français )

Timezone: Europe/Paris (GMT+02:00)

First step on the tutorial is:
Go to the WPML -> Translation Management page, click the Multilingual Content Setup and set the options in the Custom Field Translation section. (screenshot 1).

Once you do that you can see that a Chinese tab appear in Dashboard > Custom Fields (screenshot 2).

1. As you have 3 fields saying the same, I recommend you to remove what you don't need to avoid confusions.

2. Translate your custom fields, this is something I can't do as it is out of the scope.

Regards

May 21, 2018 at 9:33 am #2200081

zedC

thanks, the problem are solved. but i still have some text cannot be translated, like right side bar, i have changed the string translation but also didn't works and also i want to translated related post but it also cannot find in string translation.i have changed the widget title translation, but nothing make change.

May 21, 2018 at 9:55 am #2200106

Andrés
Supporter

Languages: English (English ) Spanish (Español ) French (Français )

Timezone: Europe/Paris (GMT+02:00)

That's great! 🙂
However for support rules we are able to handle only one issue at the time. This help us to bring you a better service and also help other users to find all the information here exposed. For that reason I have to kindly ask you to open a new thread if you need further assistance, you can assign it directly to me. In that way you don't have to wait and we can continue working on it.

Regards

May 25, 2018 at 4:21 am #2226741

zedC

Thank so much.