This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 11 replies, has 2 voices.

Last updated by veroniqueD-6 5 months, 1 week ago.

Assigned support staff: Mihai Apetrei.

Author Posts
May 6, 2019 at 8:11 pm #3752507

veroniqueD-6

I am trying to: Translate "Other Related Items", a string

Link to a page where the issue can be seen: hidden link

I expected to see: Otros artículos relacionados

Instead, I got: Other Related Items

May 6, 2019 at 8:28 pm #3752563

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi and thank you for contacting WPML Support!

I will be happy to help you with this.

The way to translate those strings really depends on how they have been implemented in the code.

1. Can you please let me know if you tried to go to WPML > String Translation and search for any of the words in that sentence?

Here is some very helpful documentation on how to use the String Translation plugin:
https://wpml.org/documentation/getting-started-guide/string-translation/

If they are not there, it could help if you scan the plugin/theme that's generating the strings and then go back to WPML > String Translation and see if the strings show up:
https://wpml.org/documentation/getting-started-guide/theme-localization/

2. If you can't find them inside the WPML > String Translation, it might be added as admin text.

This should be the normal process to translate admin texts:
https://wpml.org/documentation/getting-started-guide/translating-theme-options/

If you still can't find them, I would like to request temporary access (wp-admin and FTP) to your site to take a better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of the site files and database before providing us access.

- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box.

The private box looks like this: hidden link

I will be waiting for your response.

Kind regards,
Mihai Apetrei

May 6, 2019 at 9:15 pm #3752761

veroniqueD-6

Hi Mihai,

I don't have access to FTP. Let me back-up everything then ask for the FTP credentials. and I'll let you know

Thanks

May 7, 2019 at 11:29 am #3757085

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi.

In our case, FTP might not be needed so the WordPress credentials should be enough for the moment.

I am enabling the private fields below once again.

Kind regards,
Mihai

May 8, 2019 at 6:54 am #3764187

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi.

Unfortunately, when I try to access the login link, I get a NOT FOUND error (I'm attaching a screenshot).

Can you please check and then update the post above with the working link by using the "Edit" button?

Kind regards,
Mihai

May 8, 2019 at 5:16 pm #3769499

veroniqueD-6

Hi! Try this: hidden link

May 9, 2019 at 9:50 am #3774781

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi.

When I try that link, I am first showed the two-factor authentication message and if I click "Skip", I receive the "Error 429 Too many requests" error (attaching screenshot for both).

Can you please take a look?

Thank you.

Kind regards,
Mihai

May 9, 2019 at 5:46 pm #3778563

veroniqueD-6

Hi Mihai,

2 factor auth is not enabled for your account, is kind of weird you get that. Try this: hidden link.

May 10, 2019 at 10:05 am #3783087

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi.

Now it worked.

Can you please go here: WPML > String Translation > and search for "other related items".

You should see what I see in the screenshot I attached you below.

Simply translate that (you can try to translate both of them), check the box for using the translation and save.

Please let me know if that worked.

Kind regards,
Mihai

May 10, 2019 at 2:12 pm #3785319

veroniqueD-6

Hi Mihai,

It is inverted, Spanish shows in English and vice-versa. How I fix that?

Regards

May 10, 2019 at 4:35 pm #3786711

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi.

I am glad to hear that we are making progress.

You should be able to check the box next to the string that you want to change the language of and then follow the example in the screenshot I attached.

That should solve it 🙂

Kind regards,
Mihai

May 10, 2019 at 6:47 pm #3787457

veroniqueD-6

My issue is resolved now. Thank you!