This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 2 replies, has 2 voices.

Last updated by Andreas W. 1 month ago.

Assigned support staff: Andreas W..

Author Posts
September 10, 2019 at 6:12 pm #4548007

carinaH

I translated a website for an artist agency. The artists can create their own sed cards (I did this with the ultimate member plugin). The customers then can look for models via the ultimate member faceted search plugin. Everything could be translated perfectly except the choices. For example: "Country" could be translated, but the choices are still in German. What is really strange, I did translate all the strings but it can't be shown.

Link to a page where the issue can be seen: hidden link

Can you help me with this? It's really important because there will be many english speaking customers!

September 10, 2019 at 6:53 pm #4548341

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Thank you for contacting the WPML Support Forum.

Could you please go to WPML -> Taxonomy Translation and select the repective categories from the dropdown. Now verify if those items are translated or if any syncronization options are available. Those sync options will onlz show up if demanded by WPML.

In case all categires and items are translated correctly but still not showing up correctly I would like to have a look at the website.

I would like to request temporary access (wp-admin and FTP) to your site to take a better look at the issue. It would be better to a testing site where the issue is replicated.

You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Maybe I'll need to replicate your site locally. For this, I’ll need to temporarily install a plugin called “Duplicator” on your site. This will allow me to create a copy of your site and your content. Once the problem is resolved I will delete the local site. Let me know if this is ok with you.

IMPORTANT

Please make a backup of site files and database before providing us access.
If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this:
hidden link

Kind regards
Andreas

September 11, 2019 at 11:24 pm #4556707

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Thank you for providing access to your site.

The post type "um-forms", which is responsible for the Ultimate Member content seen on your screenshot was set to "not translate" in the WPML Settings.

I have adjusted this setting and you now do have the possiblity to translate those forms at Ultimate Member -> Formulare.

Let me know if you need any further assistance.

Kind regards
Andreas