Please make sure to update to WPML 4.3.6 and check our list of Known Issues before reporting

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 15 replies, has 2 voices.

Last updated by paulL-22 1 year, 6 months ago.

Assigned support staff: Bigul.

Author Posts
July 30, 2018 at 12:03 am #2592296

paulL-22

I am trying to:translate the content of widget

Link to a page where the issue can be seen:hidden link
hidden link

I expected to see:the translation in french

Instead, I got:the same English content

July 30, 2018 at 12:05 am #2592321

paulL-22

I still need help.

July 31, 2018 at 7:27 am #2597121

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Welcome to the WPML support forum. I will do my best to help you to resolve these issues.

Please make sure these widget strings listed for translation in WPML>>String Translation list.

In some cases, it is possible that those strings have been recognized but not associated yet to the String Translation panel for the translation. Please try the following steps after a backup and let me know your feedback.

1) Please increase the *MaxInputVars* of PHP settings to *10000*. Please check the following article for more details or contact your system admin/hosting provider for this purpose.

hidden link

2) Visit WPML>>String Translation
3) Click on the blue link at the bottom of the page: "Translate texts in admin screens »"
4) Look for an option similar to "theme_mod_saved", or something like that. Here you should find all the strings associated with your theme options.
5) Check the checkbox for your strings of interest.
6) Click on the button "Apply"(at the bottom of the page)
7) Now, all your selected strings should appear in the String Translation panel and you can translate those strings

Please check the following documentation for more details.

https://wpml.org/documentation/getting-started-guide/translating-theme-options/

https://wpml.org/documentation/getting-started-guide/string-translation/#admin_texts

--
Thanks!

Bigul

August 1, 2018 at 10:50 pm #2603498

paulL-22

I already sent the debug information the first time I created this ticket. I need you to send me a secure link so I can give you the admin user and password in order for you to fix the problem.

August 2, 2018 at 2:36 pm #2605771

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the updates. I am enabling the private option for the next reply. Please fill the private details fields after a full site backup. Check the following links for more details about our private information sharing policies.

hidden link

https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

--
Thanks!

Bigul

August 3, 2018 at 3:01 pm #2610280

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the login information. It looks like the issue is happening because of compatibility conflicts. For your kind information, the *Saved* theme is not listed on the WPML compatibility list for the themes - https://wpml.org/documentation/theme-compatibility. It does not mean that this theme is not compatible with WPML, but our compatibility team has not tested it yet.

The translation is showing when I added Section Widget in each language. I have added a new widget for French and it is showing the translation correctly. Please check the attached images for more details and let me know your feedback.

--
Thanks!

Bigul

August 4, 2018 at 12:49 am #2611872

paulL-22

Dear Bigul, the translation issue is for all widget contents. There is a lot widgets. When I sent the pictures, it was an example but didn't mean that was the only widget. Furthermore, I don't like adding widget in french, or have widget per language. If I have to do this, I would have a lot of widgets that don't look the same. I still think there is a way to technically do the translation without creating widget per language. Please take your time to help me solve this problem.

August 6, 2018 at 5:47 am #2614554

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the feedback. It requires further debugging. As I updated before your theme is not officially compatible with WPML. So please allow me to make a duplicator copy of your site using Duplicator plugin(https://wordpress.org/plugins/duplicator/) for debugging the issue on my local server.

--
Thanks!

Bigul

August 6, 2018 at 10:57 am #2615465

paulL-22

I grant you permission to make a duplicator copy of my site using Duplicator pluging. Thank you for your help.

August 6, 2018 at 6:55 pm #2617117

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the permission. I have activated Duplicator plugin on your site. But the site is not showing Duplicator menu. It may be happening because of the server caches.

So can I try it after deactivating SG Optimizer and Jetpack by WordPress.com plugins? Have you taken a site backup?

--
Thanks!

Bigul

August 6, 2018 at 9:37 pm #2617532

paulL-22

Yes you can try it after deactivating SG Optimizer and Jetpack. I have a site backup.

August 7, 2018 at 11:14 am #2619913

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the permission. The Duplicator menu was visible when I disable Memcache feature of SG Optimizer. I have enabled it back after making a Duplicator copy of the site. Will debug it further and get back to you soon. Please wait.

--
Thanks!

Bigul

August 8, 2018 at 12:59 pm #2624792

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

For your kind updates, I am getting the expected result on the local copy after adding WPML language configuration for these widgets.

Please try the following step after a site backup and make sure you are getting the expected result or not.

1) Visit WPML>>Settings
2) Choose *Custom XML configuration* tab
3) Add the following language configuration in *Custom XML configuration* field and save the changes.

<wpml-config>
  <admin-texts>
    <key name="widget_ctfw-section">
      <key name="1">
        <key name="title"/>
        <key name="content"/>
        <key name="text_size"/>
        <key name="centered"/>
        <key name="image_id"/>
        <key name="video"/>
        <key name="image_brightness"/>
        <key name="image_opacity"/>
        <key name="attachment"/>
        <key name="height"/>
        <key name="orientation"/>
        <key name="link1_text"/>
        <key name="link1_url"/>
        <key name="link2_text"/>
        <key name="link2_url"/>
        <key name="link3_text"/>
        <key name="link3_url"/>
        <key name="link4_text"/>
        <key name="link4_url"/>
        <key name="wpml_language"/>
      </key>
      <key name="2">
        <key name="title"/>
        <key name="content"/>
        <key name="text_size"/>
        <key name="centered"/>
        <key name="image_id"/>
        <key name="video"/>
        <key name="image_brightness"/>
        <key name="image_opacity"/>
        <key name="attachment"/>
        <key name="height"/>
        <key name="orientation"/>
        <key name="link1_text"/>
        <key name="link1_url"/>
        <key name="link2_text"/>
        <key name="link2_url"/>
        <key name="link3_text"/>
        <key name="link3_url"/>
        <key name="link4_text"/>
        <key name="link4_url"/>
      </key>
      <key name="3">
        <key name="title"/>
        <key name="content"/>
        <key name="text_size"/>
        <key name="centered"/>
        <key name="image_id"/>
        <key name="video"/>
        <key name="image_brightness"/>
        <key name="image_opacity"/>
        <key name="attachment"/>
        <key name="height"/>
        <key name="orientation"/>
        <key name="link1_text"/>
        <key name="link1_url"/>
        <key name="link2_text"/>
        <key name="link2_url"/>
        <key name="link3_text"/>
        <key name="link3_url"/>
        <key name="link4_text"/>
        <key name="link4_url"/>
      </key>
      <key name="4">
        <key name="title"/>
        <key name="content"/>
        <key name="text_size"/>
        <key name="centered"/>
        <key name="image_id"/>
        <key name="video"/>
        <key name="image_brightness"/>
        <key name="image_opacity"/>
        <key name="attachment"/>
        <key name="height"/>
        <key name="orientation"/>
        <key name="link1_text"/>
        <key name="link1_url"/>
        <key name="link2_text"/>
        <key name="link2_url"/>
        <key name="link3_text"/>
        <key name="link3_url"/>
        <key name="link4_text"/>
        <key name="link4_url"/>
        <key name="wpml_language"/>
      </key>
      <key name="_multiwidget"/>
    </key>
    <key name="widget_ctfw-highlight">
      <key name="1">
        <key name="title"/>
        <key name="description"/>
        <key name="click_url"/>
      </key>
      <key name="2">
        <key name="title"/>
        <key name="description"/>
        <key name="click_url"/>
      </key>
      <key name="3">
        <key name="title"/>
        <key name="description"/>
        <key name="click_url"/>
      </key>
      <key name="4">
        <key name="title"/>
        <key name="description"/>
        <key name="click_url"/>
      </key>
    </key>
  </admin-texts>
</wpml-config>

4) Visit French homepage, check the widgets are showing the translation or not

Please check the attached images and following documentation for more details.

https://wpml.org/documentation/support/language-configuration-files/#admin-texts

https://wpml.org/documentation/related-projects/wpml-compatibility-test-tools-plugin/

--
Thanks!

Bigul

August 9, 2018 at 1:54 am #2626907

paulL-22

I tried what you told me, everything looks fine except the " Give Now" button that can't be translated. Could you please check to see what is the problem. I would like to thank you for your patience and dedication.

August 9, 2018 at 1:54 pm #2629061

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the feedback. The *Online Giving* widget is showing the translation after I have added WPML language configuration(in the *Custom XML configuration* field) for the *CT Giving* widget. Please check the attached images for more details and let me know your feedback.

--
Thanks!

Bigul