This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 10 replies, has 2 voices.

Last updated by Lauren 3 months, 1 week ago.

Assigned support staff: Lauren.

Author Posts
July 8, 2019 at 7:44 pm #4165495

giuseppeM-31

Tell us what you are trying to do?
Translate the homepage
Is there any documentation that you are following?
-
Is there a similar example that we can see?
-
What is the link to your site? hidden link

July 8, 2019 at 7:52 pm #4165513

giuseppeM-31

I've been trying to translate the homepage of this website to Spanish. The theme I'm using is built with Elementor. I installed WPML, activated the plugins required and then added the translation in Spanish, completed all the translations, saved and closed. Then I edited a paragraph, re-opened the translation and there were just 4 fields, and two of them uncompleted. I did everything again, re-opened the translation and the same 4 fields appeared, everything else vanished. I don't know what can I do...

July 8, 2019 at 7:53 pm #4165515

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Thank you for contacting WPML support. I'll be happy to help you with this.

Can you tell me how you created the homepage content, and how you are trying to translate it? You can translate a page by clicking the "+" icon next to the page title when you view the list of pages. Also, if you are using a Page Builder, we typically recommend using the WPML Translation Editor. Once I have more information about how your content is created, I can send you more details on how best to translate your page.

July 8, 2019 at 7:54 pm #4165517

giuseppeM-31

Also, there are many repeated fields. In another website I used WPML those fields were combined into one, to avoid repeating the translations. Why this is not happening here?

July 8, 2019 at 7:56 pm #4165521

giuseppeM-31

Hi Lauren. Yes, I clicked on the "+" icon and I've been using the this (see attached) that I don't know how you called it. Now is showing me all the fields empty again. I really don't want to fill them again 🙏🏻

July 8, 2019 at 11:40 pm #4166157

giuseppeM-31

And now I'm only seeing those fields...

July 9, 2019 at 12:20 pm #4170661

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Do you see any strings related to this page builder ID in the string translation table? It may be that the strings translations need to be updated.

Also, please go to WPML -> Translation Management -> Translation Jobs. Do you see any jobs in progress for this particular page?

July 9, 2019 at 12:27 pm #4170689

giuseppeM-31

I did it manually with a cloned page and then I "connected" the translations (losing the functionality of the Translation Editor).

I'd love that WPML could handle these issues better, right now I'm afraid of updating any page and see all my translations gone 😥

July 9, 2019 at 12:34 pm #4170755

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

You said "I "connected" the translations (losing the functionality of the Translation Editor)". You should not lose the functionality of the translation editor if you connect the translations. Actually, it would be the opposite that if the pages are NOT connected, there would be no option to use the editor. Can you please further explain or perhaps share a screenshot so that I can better understand?

July 9, 2019 at 3:14 pm #4172373

giuseppeM-31

I had a page that I cloned and translated manually (when I was using Polylang). Then I installed WPML and all these issues appeared. I tried 3 or 4 times to translate the original page with WPML Translation Editor without success. So the solution was to use that manually translated page, choose the other language for that page and connect it to the main page.

Now if I try to translate my main page with the Translation Editor I see those 4 fields again (see attached). However, as this page was manually translated before, I see it correctly on the front end. The sad part, is if I need to make a change I'd have to make it manually with Elementor on each page, but that's better than risking my whole page using Translation Editor.

I'd like to know why I'm doing wrong so I can improve my workflow for future projects with WPML, because right now it's been really frustrating. I know that each case is different and maybe is the theme's fault, but I've been working on two websites with WPML (one with Divi and this one with Elementor), and in both I lost a lot of work for this "update page = missing/blank fields " issue.

Let me know if I can send you something (debug info, duplicator, etc) to look further into this.

Thank you very much,
Giu

July 9, 2019 at 4:54 pm #4173275

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of site files and database before providing us access.

- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this: hidden link

The topic ‘[Closed] I can't translate the homepage’ is closed to new replies.