This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 13 replies, has 2 voices.

Last updated by joachimV 1 month, 2 weeks ago.

Assigned support staff: Andreas W..

Author Posts
August 19, 2019 at 4:13 pm #4417399

joachimV

I am trying to: Translate the "prefix" / "Before" (see the attachment)

I expected to see: I thought I could translate this "Before- content" in the WP Dashboard when translating all other content on the page. But it's not their.

How can I translat the info?

August 19, 2019 at 5:50 pm #4418077

joachimV

Thank you. I tied to translate the string translation but it still doesn't show on the english published page.

hidden link

August 19, 2019 at 7:15 pm #4418847

joachimV

And I have the same problem with another widget in another template. I can't translate the template as usually and it doesn't work with the string translation either. Can you see what's wrong?

August 20, 2019 at 2:49 am #4420115

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

I would like to request temporary access (wp-admin and FTP) to your site to take a better look at the issue. It would be better to a testing site where the issue is replicated.

You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Maybe I'll need to replicate your site locally. For this, I’ll need to temporarily install a plugin called “Duplicator” on your site. This will allow me to create a copy of your site and your content. Once the problem is resolved I will delete the local site. Let me know if this is ok with you.

IMPORTANT

Please make a backup of site files and database before providing us access.
If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this:
hidden link

Kind regards
Andreas

August 21, 2019 at 3:17 am #4427635

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

You will need to translate the templates in this case. There also the title is available.

hidden link

Make sure to mark the checkboxes for each row.

Let me know if you need further assistance.

Kind regards
Andreas

August 21, 2019 at 7:58 am #4428739

joachimV

Hi, yes I tried to translate the templates but the layout the got really weird and all the text widgets moved and almost overlapped each other. So something wasn't working.

BUT I wonder what's happened with the site since a lot of the content now is removed/gone (all our custom post types). Is this due to your work? Can we get it back?

August 21, 2019 at 8:11 am #4428915

joachimV

I saw that all the plugins was deactivated, so I everything is now back now when I activated them again.

But, back to the templet problem. This it what happens if I translate the teamplat.

August 21, 2019 at 8:19 am #4429017

joachimV

And the string translation is still not working properly either. One of them is translated but then the content that should follow afterwards is missing.

And then the other one is not translated, but the content is their.

August 21, 2019 at 9:54 pm #4435171

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

I am very sorry about the issue with the plugins. I do not recall but it might be that disabled them for testing and forgot to reactivate them.

I tried tolog into the site now but it tells me: Ogiltigt användarnamn. Did you change the username in the meantime?

Before we take further steps please increase your WP Memory limit to 256M. 128M is the minimum required by WPML.
Your current values are:

MemoryLimit 3000M (PHP memory limit in php.ini)
WP Memory Limit 40M (WordPress Memory Limit in wp-config.php)
Add this code to your wp-config.php to increase WP memory:

/* Memory Limit /
define('WP_MEMORY_LIMIT', '256M');

Paste it just before:

/ That's all, stop editing! Happy blogging. /

These settings can be limited directly by your hosting provider, so I recommend you to contact and ask them to modify them directly.
If you can get even higher values It would be great.

Please also change the value of "maxInputVars" inside of your php.ini file. You are currently using a value of 1000. I would recommend you to change this setting to at least 3000 or higher.
You can find the php.ini file on your server inside the folder for your currently used PHP version 7.0.33.

In case of any doubt please contact your hosting provides and ask for assistance.

https://wpml.org/home/minimum-requirements/
Note: WPML needs a minimum WP Memory limit of 128M to work only under a minimal environment, it means, with a default theme and not other plugins installed.

Please apply the changes and comfirm the login credentials. I will then take another look at the site.

Kind regards
Andreas

August 26, 2019 at 8:13 am #4456655

joachimV

Hi,

Thank you for your reply. I have changed the memory limit but unable to find where php.ini file is. Can you help me with it and also towards the problem translation I have mentioned from the beginning? You can try with this login:

Thank you very much.

August 26, 2019 at 2:05 pm #4459471

joachimV

Hi, we decided to delete the titles in the 3 templates "FIRST-, SECOND- AND THIRD COLUMN" because they weren't necessary for the client anyway.

So now it's only the string translation we need help with. The prefix in the Theme Builder template - "House post template"

Thank you!

August 26, 2019 at 4:07 pm #4460285

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

The earlier provided credentials do not grant any access to the site anymore.

I have enabled the private box again in order provide access.

Kind regards
Andreas

August 27, 2019 at 10:32 pm #4469965

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

When using Elementor Templates it is mandatory that those templates are translated. In regards to the houses-post-template, those three columns included here are based on different Elementor Template which have not been translated yet.

Did you try to translate them already? (See screenshots)

In case the experience issues in regards to Design or single sections or strings please try to disable any additional plugin used and test if the elements are translated and visualized correctly when using only Elementor, Elementor PRO and WPML and its add-ons.

Let me know about the outcome. In case you realize a different behavior once a particular plugin is deactivated please let me know which plugin caused the issue. For more instense testing I will then need to take a copy of the website.

In regards to the changes in php.ini you should find this file inside of the folder for the currently used PHP version on your server (PHPmyAdmin). Please make sure to change the value for maxInputVars to at least 3000. You might also ask your host provider for assistance.

Kind regards
Andreas

August 30, 2019 at 8:52 am #4485377

joachimV

My issue is resolved now. Thank you!