This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 8 replies, has 3 voices.

Last updated by acodezI 3 weeks, 2 days ago.

Assigned support staff: Alejandro.

Author Posts
August 23, 2019 at 8:34 am #4445285

edens

Hello,
I am using product addons plugin,
and when i switch to another language it stays in english,
and it seems i cant translate it,
also i did not found his string and i have no luck translating it.

I have added here a screenshot so you understand the problem better

August 23, 2019 at 11:46 am #4446505

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Hello and welcome to WPML 's support forum. I'll do my best to help you solve this issue.

Could you allow me access to the site so I can take a look at it?

Could you also tell me which plugin are you using to enable the feature you can't translate please?

I enabled the related fields for you to add the credentials in a safe and private manner l.

Regards.

August 23, 2019 at 4:23 pm #4448777

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Ok, so i noted a few things.

There weren't some strings that had to be registered so i went ahead and did it for you.

To do that i had to add the following code in WPML > Settings > Custom XML Configuration:

<wpml-config>
    <admin-texts>
        <key name="wcpa_settings_key">
            <key name="options_total_label"></key>
            <key name="options_product_label"></key>
            <key name="total_label"></key>
            <key name="fee_label"></key>
            <key name="add_to_cart_text"></key>
        </key>
    </admin-texts>
</wpml-config>

I used this guide to find and write the code you find above: https://wpml.org/documentation/getting-started-guide/translating-theme-options/

you can now find said strings in WPML > String Translation

Then, i checked your plugins' documentation and found out the forms are only compatible with the native WordPress editor so you had to deactivate our WPML Translation editor in order to make it work. It's stated in their documentation: hidden link

To do that, you just had to switch off the "Use WPML's Translation Editor" found under the "Language" tab of your forms (which are found in Products > Custom Product Options).

Now all you have to do is proceed to translate the form that displays the fields on the screenshot of your first ticket thread and that's it, they will be displayed in the correct language now.

Try it and let me know how it goes.

In the meantime, it would be very helpful if you could upload the plugin into this sandbox site:
hidden link

and then try to create a form in there and add it to a product. i will send that to our compatibility team to try and improve the compatibility of the plugin so far, because right now you have to create all the fields from scratch on each language which makes the process a bit tedious and this definitely can be improved if we can work together with the author which is already a WPML Go Global partner so it should be easier to get in touch with them.

Please let me know how it goes.

August 23, 2019 at 5:09 pm #4448977

edens

Thank you for your answer,
As for the strings it is worked and i have translated them.
Abut the product forms, I am really lost and i dont know how to translate them,
When i am following their guide in the link you gave me, it is not working for me.
I am trying to translate the form to another language but all i can to translate, it the form name and not its content.

Can you help me solve it?

August 23, 2019 at 5:14 pm #4449011

edens

I have added here 2 screenshots so you will understand exactly what i have tried

August 23, 2019 at 5:55 pm #4449245

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Ok, here's what you need to do, since those products were once edited with the translation editor from WPML, you will have to first complete them.

So follow these steps:

- Briefly turn on the translation editor switch (the one that i told you to turn off)
- Go into the translations and set them all as complete and save everything
- Right now the icon of all the translated pages should be set as "edit" (pencil icon), that's what you want
- Now, turn the swithc off again
- Try to access the translation now and you'll see it will now show you the correct page and you'll be able to create the form again in the correct language.

In the meantime could you please upload the plugin in the sandbox site i linked above? i would really like to send this case to our developers so they can get in touch with the plugins' developers and improve this workflow (just so it's easier and faster for you to do this in th future)

Thanks

August 23, 2019 at 7:08 pm #4449583

edens

OK i think i got it,
also about the plugin he is not in my pc already,
but the plugin is Woocommerce product addons created by acowebs so you can contact them to receive it, that shouldnt be a problem.

thank you very much for your help, you are great man!

August 23, 2019 at 8:44 pm #4449799

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

I'm glad you feel that way!

Don't hesitate to return if you have any other doubt or question about WPML

August 24, 2019 at 8:26 am #4451105

acodezI

Hi All,
We are from Acowebs Team, Just want to check if you got the issue resolved.
Our plugins is tested as part of WPML Go Global program- it is listed here https://wpml.org/plugin/woocommerce-custom-product-addons-2/

If you are still facing issue, You can reach us at the chat support at hidden link ( will be available online IST 10:30-7:30 Mon-Fri) , Other wise you can reach at hidden link