This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: The user is using Listing Pro theme which registers an Elementor widget "Listing categories banners". The user is not able to translate the widget parameters in CTE Solution: The widget is not compatible with WPML and we should add a compatibility code. https://wpml.org/forums/topic/i-cant-translate-the-same-field-of-the-page-that-build-with-elementor/page/2/#post-4562379

This topic contains 19 replies, has 4 voices.

Last updated by sA-3 4 weeks, 1 day ago.

Assigned support staff: Jamal.

Author Posts
August 25, 2019 at 5:42 pm #4454869

sA-3

I am trying to translate of the home page that build with elementor

Link to a page where the issue can be seen: Home page

I can't see the red boxed field to translate

Instead, I got:

August 25, 2019 at 8:49 pm #4455137

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi and thank you for contacting WPML Support!

I will be happy to help you with this.

1. Can you please let me know what is the link of that page in the screenshot?

2. Can you please let me know if there is any extra plugin/add-on that you are using together with Elementor to create that content area?

3. I have noticed that your website’s WP Memory Limit is 40MB. The WP memory limit needs to be increased as the minimum requirement for WPML is 128Mb WP Memory Limit: https://wpml.org/home/minimum-requirements/

❌ Very important: please make a backup of your site (files & database) before following any of the upcoming steps ❌

Please add this to your wp-config.php file to increase WP memory:

/* WP Memory Limit */
define('WP_MEMORY_LIMIT', '256M');
define( 'WP_MAX_MEMORY_LIMIT', '256M' );

Paste it just before:

/* That's all, stop editing! Happy blogging. */

These settings can be limited directly by your hosting provider, so, if that’s the case, I recommend you to contact and ask them to modify them directly. If you can get even higher values It would be great.

Please make sure you have updated the values successfully, You can verify them from WPML >> Support page.

4. I would like to request temporary access (wp-admin and FTP) to your site to take a better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of the site files and database before providing us access.

- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box.

The private box looks like this: hidden link

I will be waiting for your response.

Kind regards,
Mihai Apetrei

August 27, 2019 at 4:06 pm #4468385

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi and thank you for the credentials.

I can confirm that they work.

I will spend more time on this and I will get back to you as soon as I have more feedback.

I will leave the ticket assigned to myself for the moment.

Kind regards,
Mihai Apetrei

August 28, 2019 at 2:56 pm #4475253

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi and thank you for your patience.

From what I can see, those fields are listing-category shortcodes.

I went to WPML > Settings > Custom Fields > and set that field to "Translate" (I will also attach a screenshot so that you can understand what I mean).

What I would need you to do now is this:

1. First, create a full backup of the site

2. Now please go to the original/default language homepage (hidden link), make a small change and re-save the page

3. Now please go to the translation (hidden link) and see if the fields are now showing up

Please let me know how that goes.

Kind regards,
Mihai

August 29, 2019 at 1:50 am #4477085

sA-3

Hi Mikai,
I did what you said. But it am not able to translate these fields. These fields does not appear on the translate screen.

Regards

August 29, 2019 at 3:41 pm #4482447

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi.

Thank you for your feedback and for following the steps I recommended.

I will spend more time on this and I will get back to you as soon as I have more feedback.

I will leave the ticket assigned to myself for the moment.

Kind regards,
Mihai

August 30, 2019 at 10:07 am #4486283

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi and thank you very much for your patience.

No matter what I tried, it did not work.

I created a sandbox testing environment on the link below (one-click login):
hidden link

WPML + the WPML add-ons are already installed and I set up the same languages like the ones on the live site, all I would need from you is to install the theme and try to recreate the issue (the idea of a clean sandbox environment is to avoid as much as possible to add any other extra plugins that are not needed, so we would need just the WPML plugins and whatever is needed to recreate the issue - theme + plugin/s - only if needed - Elementor for example).

If the issue is going to happen on our servers, too, that's when I can forward this to our Compatibility team as I think this might be a compatibility issue after all.

Will you please let me know when that's done and what is the result so that we can move forward with this?

Thank you very much for your cooperation.

I will be waiting for your response.

Kind regards,
Mihai

August 31, 2019 at 9:47 pm #4491489

sA-3

Hi,
We installed the theme on your sandbox.
Regards

September 2, 2019 at 7:48 am #4495017

sA-3

Hi Team,
Any update on this ?
Regards

September 3, 2019 at 3:31 pm #4505843

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Hello,

Mihai has a few days vacation. If you don't mind I'll continue resolving this issue with you.

Unfortunately, our server provided by Mihai is not stable, see the attached image. And I don't have SSH or FTP access de resolve the issue and see the reproduction there.

I have to kindly ask you to do it again on a new website. This time I'll save the SSH/FTP access to recover it in the worst cases.
hidden link

In my opinion, too, this is a compatibility issue with Elementor. I think it is related to translating the taxonomy terms in the Elementor module. Even if the terms are translated (Yeme & İçme->Eat & Drinks , Tarihi Mekanlar->Historical places). The Elementor module is not pulling the translation and showing them. I am not sure if this should be translated in the translation editor. But rather pulled automatically from your taxonomy(Listing categories) translations.

Thank you,
Jamal

September 3, 2019 at 4:31 pm #4506367

sA-3

Hi Jamal,
I uploaded the theme to your new site. We are waiting your investigation.
Regards

September 3, 2019 at 5:01 pm #4506499

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Hi,

Thank you. I still need you to help in the reproduction of the issue. This would involve in general the following:
1. Configure WPML similarly to your website(default language).
2. Creating a 2 or 3 listing categories and translate them.
3. Creating a couple of listing (assigned to the listing categories) and translate them.
4. Adding a couple of Elementor modules for listing categories in the homepage.
5. Translating the homepage.

If the issue is present in this clean install too, I'll escalate the issue to our compatibility team. Please note any additional steps you may have done during this reproduction to inform the developers about them too.

Thank you for your collaboration.
Jamal

September 4, 2019 at 5:31 am #4508403

sA-3

Hi Team,
I did what you said. If you could not resolve, please escalete this. It took so long time.
Regards

September 4, 2019 at 9:46 am #4509751

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Hello,

I will indeed escalate the ticket to our compatibility team. The "Cityo" theme registers some Elementor modules. You have been using the "Apus Listings Category Banner" module(theme-elementor-modules.png) which links to the listings category page.

To be able to reproduce, I had to:
1. Activate WPML String Translation and WPML Translation Management.
2. Make Listing categories translatable in WPML->Settings->Taxonomy translation
3. Translate the taxonomy terms.
4. Remove the current homepage translation.
5. Translate the homepage again.

The URLs were translated correctly but not the categories terms(after-translation.png).

The compatibility team will look into this issue and we'll get back to you as soon as possible. In the meantime, you can translate these modules manually. See the attached image after I entered manually in Elementor Editor the translated taxonomy terms labels(after-manual-translation.png).

Please note, that this was tested in the Sandbox with "language in URL parameter", you have "language in directory" in your website. I invite you to test that also in the Sandbox server.

Best regards,
Jamal

September 10, 2019 at 8:09 pm #4548773

sA-3

Hi Team,
Any update on this issue?
Regards