This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 3 replies, has 2 voices.

Last updated by cristinaV-7 1 month ago.

Assigned support staff: Noman.

Author Posts
September 11, 2019 at 7:28 pm #4556155

cristinaV-7

Tell us what you are trying to do? I want to translate the labels inside the social share buttons from from the "Social Pug" plugin.

Is there any documentation that you are following? no

Is there a similar example that we can see? look at the social share buttons in single posts like: hidden link

What is the link to your site? hidden link

The text for these labels are defined in the settings of Social Pug (see image attached). But from there I can only define them in one language. I tried looking up these strings in the WPML Strings Translation, but they don't show up there.

How can I translate them?

September 12, 2019 at 5:40 am #4558447

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Thank you for contacting WPML Support. To take a closer look on this issue, please provide temporary access (WP-Admin and FTP Login info) to your site, so that I can look into your setup and debug the issue.

Your next answer will be private which means only you and I have access to it.

✙ I would additionally need your permission to de-activate and re-activate Plugins and the Theme, and to change configurations on the site. This is also a reason the backup is really important.

Thank you

September 12, 2019 at 3:50 pm #4562637

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

1. I have tried to enable label fields from WPML >> String Translations -> (at the bottom of page) Translate texts in admin screens », -> >> ‘- dpsp_location_content’ > networks but it is not saving when I click on the Apply button.

2. To fix this issue, please increase MaxInputVars to 10000 or more. For this, please try to set these variables in your php.ini:

max_input_vars = 10000;
suhosin.post.max_vars = 10000;
suhosin.request.max_vars = 10000;

You may need to contact your hosting provider to set them.

- Please add this to the top of wp-config.php to increase WP memory:

/* WP Memory Limit */
define('WP_MEMORY_LIMIT', '256M');
define( 'WP_MAX_MEMORY_LIMIT', '256M' );

After increasing max_input_vars value (screenshot attached) please follow the above steps and hit apply button. Then please go to String Translation and you will see newly enabled values at the top of the page and ready for translation, add the translation for that string and check Translation is complete checkbox and press the Save button.

To check the minimum MaxInputVars value required to save the page, please follow this doc:
https://wpml.org/documentation/getting-started-guide/translating-theme-options/#resolving-issues-with-maxinputvars-value

3. For now, I have fixed this issue by using our XML method and added the following XML code:

<wpml-config>
    <admin-texts>
        <key name="dpsp_location_content">
            <key name="networks">
                <key name="facebook">
                    <key name="label" /></key>
                <key name="twitter">
                    <key name="label" /></key>
                <key name="email">
                    <key name="label" /></key>
                <key name="print">
                    <key name="label" /></key>
            </key>
        </key>
    </admin-texts>
</wpml-config>

In WPML >> Settings >> Custom XML Configuration section and now labels/strings are available for translation.

I have added translation from WPML >> String Translation and it showing correctly on frontend.

Could you please check and confirm?

Thank you

September 12, 2019 at 10:14 pm #4564409

cristinaV-7

Very thorough and helpful response. My issue is resolved now. Thank you!