Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Sun Mon Tue Wed Thu Fri Sat
- 8:00 – 12:00 8:00 – 12:00 8:00 – 12:00 8:00 – 12:00 8:00 – 12:00 -
- 13:00 – 17:00 13:00 – 17:00 13:00 – 17:00 13:00 – 17:00 13:00 – 17:00 -

Supporter timezone: Asia/Ho_Chi_Minh (GMT+07:00)

This topic contains 2 replies, has 2 voices.

Last updated by Long Nguyen 1 month, 2 weeks ago.

Assisted by: Long Nguyen.

Author Posts
February 22, 2024 at 6:46 pm #15335347

romainO-2

I have created ACF fields that are used in a Divi theme builder project template.
One of these fields was a simple text field that I have transformed into a WYSIWYG field. This new field works well in the source language (french) but I can't apply this change to english and spanish projects. I have tried to update translations of :
- the project template
- the ACF fields
- the project itself
But I keep on seeing code (/br, or

    ...) in translated pages on frontend instead of line breaks or bullets.
    You have to now that I have also modified one of Divi module options in the French project template ("display raw html", see screenshot) that is important and should be also applied to other languages for them to display properly. Maybe it's this setting that I cannot translate.

    Project with "Mission" text ok : hidden link

    Project translation with problem on "mission" text : hidden link

Capture d’écran 2024-02-22 à 19.42.26.png
Capture d’écran 2024-02-22 à 19.42.20.png
February 22, 2024 at 7:52 pm #15335513

romainO-2

I have duplicated the project template and assigned it to the last project only (the one I sent you the link).

I have translated it again using your last recommendations and I got the same results.

Then I opened the theme builder interface after switching the backoffice language and I realized that, indeed, the "display raw html" was not checked in Spanish and English (the layout translation dit not copy this setting).

I changed it manually and now this template is well translated in all languages.

I know modifying theme builder content after switching the backoffice langage can be risky.
Until a few weeks ago, I did all the translations in this website via the DIVI Builder or the theme builder.

I have recently changed all my translation methods. I'm now using your most recent protocols involving the advanced translation editor and the translation management menu.

I would like to be able to continue in this direction and no longer "tinker" as I did before. So can you advise me on how to solve this problem without "cheating"? I could thus apply it to the first template which affect the entire site projects.

February 26, 2024 at 7:51 am #15342496

Long Nguyen
Supporter

Languages: English (English )

Timezone: Asia/Ho_Chi_Minh (GMT+07:00)

Hi Romain,

Thank you for contacting WPML support, I’m happy to help you with this issue.

Can you please help me replicate the issue on a clean installation of WordPress? You can access the admin area with this link hidden link

Kindly follow the steps below:

- Don’t restore your site there.
- Install the ACF plugin.
- Try to replicate the issue with minimal steps.
- Then let me know the steps to replicate it.

Looking forward to your reply.
Thanks

The topic ‘[Closed] I can't update an ACF field type in translates languages’ is closed to new replies.