This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 1 reply, has 2 voices.

Last updated by Rohan Sadanandan 1 month ago.

Assigned support staff: Rohan Sadanandan.

Author Posts
September 13, 2019 at 2:19 pm #4569343

laura-ashleyG

I am trying to: Update WMPL to the latest version.

When I try to update, I get the message:
Update Failed: Download failed. cURL error 35: SSL connect error.

Please help !

September 16, 2019 at 6:54 am #4576639

Rohan Sadanandan
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for contacting WPML Support.

Can you check if your server has the CURL extension for PHP installed? This extension is necessary to communicate with our server and validate these configuration files.

This issue can also be caused if your server has some firewall that prevents access to external sites.

Please, could you contact your web host and ask about this? They may need to add some WPML URLs in the settings whitelist. If so, add these URLs:

- https://wpml.org
- hidden link
- hidden link
- hidden link
- hidden link

These are the domains that WPML needs to access to install or notify the updates or even install the plugins via the Commercial tab.

After following these steps, please let me know if the problem persists.

You can also install the plugins manually

=> https://wpml.org/account/downloads/

To do a manual update please follow these steps:

1. Backup your database – see for example: http://wordpress.org/extend/plugins/wp-db-backup/

2. Deactivate the existing WPML plugin and add-ons.

3. Delete the plugin files – this does not delete your translations. You will simply delete the plugin files from your "wp-content/plugins" folder NOT the database records.

4. Download the updated plugins from our servers and upload them to the plugin directory.

5. Activate the WPML plugin and add-ons.

Also, I request you to update the WP Memory Limit to at least 128MB which is the minimum requirement for WPML: https://wpml.org/home/minimum-requirements/

/** Memory Limit */
define('WP_MEMORY_LIMIT', '256M');
define( 'WP_MAX_MEMORY_LIMIT', '256M' );

Paste it just before:

/* That's all, stop editing! Happy publishing. */

Thanks,
Rohan