This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem:

The Icon Box and Info Box module from WPBakery are not translatable.

Solution:

Insert the following code in WPML -> Settings -> Custom XML Configuration (tab).

<wpml-config>
    <shortcodes>
        <shortcode>
            <tag>stm_icon_box</tag>
            <attributes>
                <attribute>title</attribute>
            </attributes>
        </shortcode>
        <shortcode>
            <tag>stm_info_box</tag>
            <attributes>
                <attribute>title</attribute>
            </attributes>
        </shortcode>
    </shortcodes>
</wpml-config>

After that, the Icon Box and Info Box would be translatable.

Tagged: 

This topic contains 9 replies, has 2 voices.

Last updated by nicolaA-5 4 months, 3 weeks ago.

Assigned support staff: Itamar.

Author Posts
May 15, 2019 at 1:26 pm #3817031

nicolaA-5

Tell us what you are trying to do?
I want to translate Info Box and Icon Box, but in the WPML front-end I can't visualize the field for translation
Is there any documentation that you are following?
No
Is there a similar example that we can see?
No
What is the link to your site?
hidden link

May 15, 2019 at 5:48 pm #3819245

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi.

Can you please elaborate on the problem?
Are Info Box and Icon Box elements of the WPBakery Page Builder?
If so then, please review our documentation on how to work with PWML and WPBekary.
https://wpml.org/documentation/plugins-compatibility/how-to-build-multilingual-sites-with-wpbakery-page-builder-and-wpml/

Also, I can see that you are using cache plugins on your site (SG Optimizer, WP Supper Cahce). So you might have a cache issue. Please clear the cache from your site and see if the problem persists.

Thanks,
Itamar.

May 16, 2019 at 7:07 am #3822353

nicolaA-5

Hi Itamar,

yes, I am using WPBakery Page Builder. I have created some Info Boxes (capture 3) and some Icon Boxes. Now, the problem is that for some Icon Boxes, I can add a translation, while for others I can't, because I can't visualize the translating field (capture 4). For Info Boxes, it doesn't work at all. I tried to uninstall one of the 2 plugins to clean cache and delete the cache as well, but the problem is still there.

May 19, 2019 at 10:58 am #3841447

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi and sorry for the late reply here.

The following might be related to your issue.

1. By looking at the debug info that you have attached I can see that your server is running an older version of MySQL and also your server WP Memory Limit is set to 40M.
Our recommendations are to have the following as minimal requirements:
- PHP 5.6 and above (this OK with your installation) with a WP Memory Limit of at least 128MB and more if possible.
- MySQL 5.6 and above (this OK with your installation).
Please follow this link for detailed documentation:
https://wpml.org/home/minimum-requirements/
Is it possible for you to change those to the minimum requirement?
You may need to contact your hosting provider for that.
Meeting those baseline requirements is most critical before starting to debug and sometimes solves strings issues like you experiencing.
Most important is to raise the WP Memory Limit.
Please try to raise it before you contact your hosting company.
You can try and do it from the wp-config.php file in your WordPress installation.
Insert this code in that file.

/** Memory Limit */
define('WP_MEMORY_LIMIT', '256M');
define( 'WP_MAX_MEMORY_LIMIT', '256M' );

Add it before this line:
/* That's all, stop editing! Happy blogging. */

---------------------------------------------------------------------------------------

2. Please increase the *MaxInputVars* of PHP settings to *10000*. Please check the following article for more details or contact your system admin/hosting provider for this purpose.

hidden link

After following the above, you might need to re-save the original page and then edit the translation.

Could you please perform those procedures and see if they help?

Thanks,
Itamar.

May 21, 2019 at 3:58 pm #3857049

nicolaA-5

Hi Itamar,

I tried to performe these procedure, I contacted my hosting provider for this. Unfortunately I didn't solve my issue. In fact, I have re-saved the original page, but when I open the translating page, I still don't see the fields to digit in (the one associated with some Icon Box and Info Box). Which means that I can still translate them using WPBakery Page Builder, but, when I modify the original page, I loose my translations.

May 22, 2019 at 2:20 pm #3866605

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi.

I think that it would be better for me to check things on your site. Could you please let me have access to your site and explain to me exactly how to see the issue?

If you need further help with this, please share the access details to your site with me.
I'm enabling a private message for the next reply.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- - Please make a backup of site files and database before providing us access. --

Thanks,
Itamar.

May 23, 2019 at 4:43 pm #3877973

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi and thanks for the access details.

I've investigated this issue on your site. First, it is essential for me to say that the Icon Box and Info Box are not officially supported for translation by WPML. You can find the full list of supported modules here.
https://wpml.org/documentation/plugins-compatibility/how-to-build-multilingual-sites-with-wpbakery-page-builder-and-wpml/#supported-modules

Nevertheless, it is possible to add support for those modules, and I did it according to the instructions here.
https://wpml.org/documentation/support/language-configuration-files/#page-builder-content
In WPML -> Settings -> Custom XML Configuration (tab) where I inserted the following code, I could see that you tried it also. But the tag name was wrong there. You need to take it from the shortcode's name.

<wpml-config>
    <shortcodes>
        <shortcode>
            <tag>stm_icon_box</tag>
            <attributes>
                <attribute>title</attribute>
            </attributes>
        </shortcode>
        <shortcode>
            <tag>stm_info_box</tag>
            <attributes>
                <attribute>title</attribute>
            </attributes>
        </shortcode>
    </shortcodes>
</wpml-config>

Before trying it on the homepage, I've created a test page here.
hidden link
For it to work on the homepage, I needed to go to each Icon Box and Info Box elements and make a small change in them. I add space. Then I updated the page and edited the translation. Now the title and content of the Info and Icon modules are showing for translation. Please see the attached screenshot info-icon-ok.jpg.
You can now translate them and finish the translation of the homepage.

While checking things on your site, I could see that a few fields that were set to copy and then showed for translation in the Translation Editor were not supposed, and there was no need for them to be set to 'Translate'. Please see the attached screenshots fields-set-to-trans-1.jpg and fields-set-to-trans-2.jpg. The fields that I was sure about them I set them to 'Copy'.

Regards,
Itamar.

May 24, 2019 at 8:09 am #3882119

nicolaA-5

Dear Itamar,

thanks a lot for your support, it works perfectly now. Just one more question: in case I need to add more Info Box and Icon Box elements on other pages, you said that you had to make a small change (add space) on them. Can you detail more about this procedure?

May 26, 2019 at 9:41 am #3891507

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi.

I'm not sure if it 100% necessary but just in case that it does here is what you need to do. You need to edit those modules and change something little. This way when you translate it WPML will notice that there is a change from the original module and will enable it re-translation. When I wrote "add space," I meant literally to stand with the cursor at the end of a sentence and press the space bar on the keyboard. The same way you can add a comma or a dot.
Please let me know if it is clear now.

Regards,
Itamar.

May 27, 2019 at 8:05 am #3894423

nicolaA-5

My issue is resolved now. Thank you!