This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Author Posts
July 21, 2019 at 8:29 pm

leandroP-2

I am trying to:

I changed the language on my WordPress installation from es_ES to es_AR, but I don’t see the changes taking place on the front end.

I also changed the locale for the theme language from es_ES to es_AR, I don’t see any change either.

I deleted my plugin cache but everything looks the same.

Link to a page where the issue can be seen: hidden link

I expected to see: a change in the language, from es_ES to es_AR.

Instead, I got: I still see es_ES.

July 22, 2019 at 4:21 am #4253759

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Thank you for contacting WPML support.

I see es-ar correctly: hidden link on your site.
Please check this in incognito mode.

You did not see it may be because of the caching or CDN.
Please check again.

Let me know if you need anything else regarding this.

Regards,
Riffaz.

July 25, 2019 at 11:16 am #4282379

leandroP-2

I see that as well, but my locale is still showing some es_ES strings. This is weird.

July 25, 2019 at 5:01 pm #4285309

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

I see that as well, but my locale is still showing some es_ES strings.
- could you please show a screenshot of this?

Regards,

August 1, 2019 at 12:33 am #4317889

leandroP-2

Sorry for the late reply.

Take a look at this page: hidden link

At the end it says:
«Quiero suscribirme a la lista de difusión«

The « character is part of the es_ES locale as you can see here: hidden link

es_AR doesn't uses the " character instead. I checked on a clean WordPress installation.

August 1, 2019 at 7:46 am #4319429

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

When I go to this page view-source:hidden link if I check the source code I see " in the es-ar.
Please check this screenshot: hidden link

Are you asking about something else?
If yes, could you please show some screenshots for better understanding?

Regards,

August 1, 2019 at 2:14 pm #4322605

leandroP-2

You visited the page in English, you should visit the page in Spanish and you'll see this at the bottom: hidden link

I know the source code shows es-ar, but visually there are still strings from es_ES, for example the « character.

August 4, 2019 at 12:40 pm #4336379

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

I understand what you say now.
You will get reply again regarding this by Monday evening from a Spanish supporter.
That will be easier to communicate and to understand the contents.

Please be patient.

Regards,

August 5, 2019 at 1:51 pm #4341045

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hi

I´ll be helping you now.

I found an old WPML forum ticket that described the same issue here:
https://wpml.org/forums/topic/wpml-turning-double-quotes-to-arrows-on-russian/

Installing the plugin https://wordpress.org/plugins/wp-typography/ resolved the issue and seems to also work in your case. It´s currently installed/activated and the double quotes are preserved.

However, the problem seems to be coming from WordPress. Here is described a more complete solution that you can try if you don´t want to keep the above mentioned plugin installed:
https://wordpress.org/support/topic/wordpress-now-replaces-the-quotes-with/

I hope either one of these solutions will resolve your issue.

August 5, 2019 at 6:15 pm #4342543

leandroP-2

My issue is resolved now. Thank you!