We have just released WPML 4.3.3. Before reporting issues please make sure to update - this version resolves all known issues with the major WPML 4.3 release

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 3 replies, has 2 voices.

Last updated by Dennis 3 months, 3 weeks ago.

Assigned support staff: Dennis.

Author Posts
July 17, 2019 at 8:06 am #4227093

linA

I am trying to: Translate my site from English to Chinese.

Link to a page where the issue can be seen: hidden link

I expected to see: Translated page

Instead, I got: nothing show

I have completed all the translation to 100% and clicked saved but my translation does not show. When I go back and click translation bottom again, it become 73% complete. No matter how many time I completed, click save and exit, open again completion stays at 73%.

Also I am trying to translate my homepage (front page/landing page) but when i click translate bottom, it does not open. Completely froze.

July 17, 2019 at 9:41 am #4228303

Dennis

Hi,

Welcome to WPML Support forum.

Please increase the WP Memory Limit (your current setting is 40M). Minimum requirements are 128Mb:

https://wpml.org/home/minimum-requirements/

You can add this to wp-config.php to increase WP memory:

/** Memory Limit */
define('WP_MEMORY_LIMIT', '256M');
define( 'WP_MAX_MEMORY_LIMIT', '256M' );

- Add it above the line

 /* That's all, stop editing! Happy blogging. */ 

Also, I would like to recommend you to increase your max input vars, currently it has a value of 1000 in your WordPress Dashboard > WPML > Support section.

Please, try to increase it to 5000. You might need some assistance from your host to properly set this up.

See:
hidden link
hidden link

Then:

-edit the page having issue. edit it on default language.
-make a small change (e.g. change heading text ). click 'Update.
-undo the small change. click 'Update'
-translate the page to secondary languages. Save and close.

Does it help? Please let me know.

Kind regards,
Dennis

July 18, 2019 at 1:38 am #4234079

linA

Hello
I am using Bluehost as my sever and they helped me increase WP Memory Limit and max input vars just like you suggested but still doesnt work. I still have the same issue... translated page do not show and translation process always stays at 73%...

please see below for detail.
hidden link

July 18, 2019 at 6:36 am #4235359

Dennis

Hi,

Thank you for your reply.

To debug the issue further, please enable the WordPress debug log. This will allow us to see if any PHP errors are being produced.

More Info: https://codex.wordpress.org/Debugging_in_WordPress

Edit wp-config.php and insert the following lines:

/*enable debugging*/
define( 'WP_DEBUG', true );
define( 'WP_DEBUG_LOG', true );
define( 'WP_DEBUG_DISPLAY', false);

- Add it above the line

 /* That's all, stop editing! Happy blogging. */ 

-Try to reproduce the issue.
-Locate the debug log in: /wp-content/debug.log using FTP, then edit/view the content of the file.

Do you see any php errors related to WPML? Could you please share the debug.log content to us? You can use https://pastebin.com/ so you can just share the link to us.

Also, could you please check for a possible theme and plugin conflict. To do so,

-backup your site completely.
-deactivate all non-WPML plugins, except the plugins required to debug.
-switch to a WordPress default like Twenty Sixteen. Its will tell us if there is an interaction issue with your theme.
- If the problem disappears, start activating one at the time to track where the incompatibility is produced.

Please let me know your results.

Kind regards,
Dennis

The topic ‘[Closed] I completed all translation but it doesnt show.’ is closed to new replies.