We have just released WPML 4.3.3. Before reporting issues please make sure to update - this version resolves all known issues with the major WPML 4.3 release

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 19 replies, has 2 voices.

Last updated by yee-fongC 2 years, 2 months ago.

Assigned support staff: Bobby.

Author Posts
September 3, 2017 at 7:01 pm #1356799

yee-fongC

I am trying to: change my static frontpage to a newly created page.

Link to a page where the issue can be seen:

I expected to see: the frontpage to be the one I selected

Instead, I got: the frontpage always go back to the original one. This issue only happen after I activate WPML

September 4, 2017 at 7:12 am #1356908

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-08:00)

Hello,

Thank you for contacting WPML Support,

1. Deactivate WPML , then switch your Static front page from within Settings -> Reading , and now enable WPML.

Does the Front page change ?

2. What are your results if you go to Settings -> Reading and change your static front page again ?

3. Please clear your WPML and browser cache and let me know your results

to clear the WPML cache go to WPML => Support , and click on "Troubleshooting"

September 4, 2017 at 7:24 am #1356920

yee-fongC

Thank you for your replies.

1. Deactivate WPML , then switch your Static front page from within Settings -> Reading , and now enable WPML.

Does the Front page change ?

This is what happen:
a. Deactivate WPML - I can select the static front page that I want.
b. Reactivate WPML - The static front page change back to the Front page before I deactivate WPML.

2. What are your results if you go to Settings -> Reading and change your static front page again ?

I could not change the Front page.

3. Please clear your WPML and browser cache and let me know your results

I performed a reset using reset function at the bottom of the troubleshoot page. The result is the front page will always stay at the page that I have selected before I set up WPML. After I set up WPML, I could not change the front page anymore.

September 4, 2017 at 8:07 am #1356998

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-08:00)

Hello,

If possible i would like to take a closer look as i am not able to replicate this on a local install.

You should be able to change your static page even with WPML activated.

**Before we proceed I recommend to please take FULL BACKUP of your database and your website.**
I often use the Duplicator plugin for this purpose See: http://wordpress.org/plugins/duplicator/

I would like to request temporary access (wp-admin and FTP) to your site to fix the issue.
(preferably to a test site where the problem has been replicated if possible)

You will find the needed fields for this below the comment area when you log in to leave your next reply.
The information you will enter is private which means only you and I can see and have access to it.

Thank you,
Bobby

September 4, 2017 at 8:27 am #1357035

yee-fongC

Hi, I have provided the WP admin access. Unfortunately, I don't not have ftp access because my website is hosted on WordPress.com

September 4, 2017 at 9:33 am #1357266

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-08:00)

Hi There,

I tried to login but i was not able to as it prompts me that the user id does not exist.
If you could please double check and let me know , i have enabled the private reply once again.

Thank you !

September 4, 2017 at 10:21 am #1357381

yee-fongC

Hi, sorry it is my mistake. I have resend you the login id. Thanks.

September 4, 2017 at 8:29 pm #1358649

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-08:00)

Hello,

Thank you i took a closer look.

I would like to test for a plugin compatibility , as it seems that a 3rd plugin might be causing this.

please test this:
-Back up your site first
-Deactivate all non WPML related plugins
-Switch for a moment to a WordPress default theme like Twenty Fourteen.
-If the issue is gone, activate one by one to see with wich one there is an interaction issue

Let me know your results please or let me know if you would rather me do this since i have access

Kind Regards,
Bobby

September 5, 2017 at 2:11 am #1358817

yee-fongC

Hi, I have deactivated all other plugin but it is not working. Kindly assist.

September 5, 2017 at 9:53 am #1359521

yee-fongC

Dear Bobby,

May I know if you are looking into it please? Thanks.

Regards,
Yee Fong

September 5, 2017 at 11:31 am #1359743

yee-fongC

Dear Bobby, this is rather urgent. Do you mind giving me an update of the status please? Thanks.

September 5, 2017 at 1:04 pm #1360057

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-08:00)

Hi There,

You have 2 drop-in plugins enabled for cache that i believe are causing this.

advanced-cache.php
Advanced caching plugin.

object-cache.php
Memcached
External object cache.

Memcached backend for the WP Object Cache.

you can see these by going to plugins and then "drop-ins"

You will need to deactivate these using FTP.

Do you not have access to your FTP or cpanel at all ?

Also i cant deactivating Vaultpress, Jetpack, or Akimiset plugins either to test.

September 5, 2017 at 1:20 pm #1360084

yee-fongC

Dear Bobby, thanks for the finding. I do not have any access to ftp. Do you mind contacting the WordPress support? Thanks.

September 5, 2017 at 3:04 pm #1360340

yee-fongC

Dear Bobby, the WordPress engineer said that the cache plugin is required for all WordPress.com website and they can't disable it.
Even if I change my static front page after deactivate WPML, the static front page will change back to the previous one after I reactivate WPML.

September 5, 2017 at 6:31 pm #1360687

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-08:00)

If you are not planning on changing the static front page at the mean time you can just RESET WPML like you did before and set the correct static front page before configuring WPML.

I do believe this might be related to the cache plugins that are set as drop ins but it needs further testing on my local enviroment for me to verify.

Would it be possible to provide me with a duplicator package or maybe create a test enviroment on a different server or even your local host to test this and see if you experience the same issue.

At the meantime i will get the opinion of our developers as well regarding this, but if you could test on your local host or provide me with a test site not hosted on wordpress.com