Skip Navigation

This thread is resolved. Here is a description of the problem and solution.

Problem: when trying to see the translated WooCommerce products in the front end, it returns error 404

Solution: the issue is with base permalinks, as some of them were identical in different taxonomies and this is not possible. Resetting the permalinks to default solves the issue.

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 2.47 hours from now. Thank you for your understanding.

This topic contains 9 replies, has 2 voices.

Last updated by yunfeiS 1 year, 5 months ago.

Assigned support staff: Laura.

Author Posts
February 16, 2019 at 7:38 am

yunfeiS

The product page in translated language couldn't be access, it shows 404.
But after I deactive the plugin "WPML String Translation", the page is accessable.

February 16, 2019 at 8:33 am
February 16, 2019 at 8:43 am
February 16, 2019 at 9:11 am #3207646

yunfeiS

I updated the first one reply it includes the copy, if you need something pls tell me. Thanks.

February 16, 2019 at 1:43 pm #3207854

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

Hi,

thanks for the file or the explanation, but I see you uploaded a .daf file. Wouldn't be possible to have a .zip file?

February 17, 2019 at 5:14 am #3208647

yunfeiS

I think I forgot to upload the file "installer.php", I already uploaded this one to the same sharing link from which you downloaded the files.
You could make a zip file with these files.
Thank you!

February 18, 2019 at 3:54 pm #3213191

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

Hi,

I managed to install your Duplicator but I'm having some trouble because in the front end I get this notice:
恭喜, 站点创建成功!
站点创建成功,本页面由系统自动生成。
本页面在FTP根目录下的index.html
您可以删除或覆盖本页面
FTP相关信息,请到宝塔后台查看
我们为您提供了完善的数据备份功能,请到后台进行相关设置

in the backend everything works fine but of course I can't check anything. I tried to deactivate plugins to make things work but with no success.
I'll try re-installing the duplicator but if you have other suggestions please let me know.

February 19, 2019 at 3:05 pm #3217379

yunfeiS

The chinese sentences mean you made the site successful.
Did you login through the admin access?
The supportor Bigul builded the site with duplicator for my last issue, could you ask for some informations from him?

February 20, 2019 at 12:58 pm #3221836

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

Hi,

yes I log into the site, and in the backend everything works, but if I go to the front end I get that message, in any page.

I asked Bigul for suggestions but after he imported the user table (which I did too) he managed to access the site and he didn't meet my issue.

Could you try sending a complete Duplicator? If you don't want to send customer data, you could try removing them with this query: https://wpml.org/documentation/privacy-policy-and-gdpr-compliance/how-to-remove-personal-information-from-your-database-for-support/
Please do a complete backup of the database before attempting this. I'll enable a private reply.

February 20, 2019 at 7:35 pm
February 21, 2019 at 12:46 pm #3227477

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

Hi,

I found the problem on your site. It's about permalinks.
If you see, the Chinese page was missing the product category. I think because you had a strange permalink format, also in WooCommerce -> WooCommerce Multilingual -> Store URLs the Chinese store url was a translation of Chinese, I think that's because you have 2 store pages.

Now if you go to hidden link you can see it's working.

What I did:
- in Settings -> Permalinks I removed all instance grocery-store-shop-wh-wuhan-china (having multiple identical slugs can lead to errors, so this is what happened probably)
- change the bases in product-category, product-tag, product-attribute
- change the custom base to /product/%product_cat%/
- then I went to WooCommerce -> WooCommerce Multilingual -> Store URLs and copied the translated slug.

This would fix the issue. Could you see if it works for you too?
Once it's visible if you want to change the default slugs please pay attention to not use the same slug in different languages or for different kind of content and taxonomies.

Let me know if this helps you or if you need further assistance.

February 21, 2019 at 1:47 pm #3227788

yunfeiS

okay, thank you!
It's done.
I went to WooCommerce -> WooCommerce Multilingual -> Store URLs and copied the translated slug, and copied the orignal english url of the product page to the Chinese url.

February 21, 2019 at 1:47 pm #3227792

yunfeiS

My issue is resolved now. Thank you!