This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 3 replies, has 2 voices.

Last updated by Mihai Apetrei 1 year ago.

Assigned support staff: Mihai Apetrei.

Author Posts
October 2, 2018 at 8:07 pm #2782667

franoM

Tell us what you are trying to do?
I deleted 3 product mistakenly from default language but their translations are still present and I am not able to find them

Is there any documentation that you are following?
No

Is there a similar example that we can see?
Yes on fabluxe backend there are 316 products in dutch but 319 in english

What is the link to your site?
fabluxe.nl for dutch version and fab-luxe.com for english version

October 3, 2018 at 2:30 pm #2784842

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi and thank you for contacting WPML Support!

I will be happy to help you with this.

Please help me to understand a bit better what are you actually looking to do.

From what I can understand, you deleted 3 products by mistake but you still have the EN translation for each of the 3 products stored in the database.

Now, my question is: do you want to recover the 3 products you deleted by mistake or do you want to find the other 3 translations and delete those, too?

Sometimes screenshots illustrating what you mean may go a long way to clarify what words fail to transmit, so if you like, make use of “upload an image” below the comment area.

I will be waiting for your answer.

October 4, 2018 at 5:15 pm #2788371

franoM

Hello sir,

Yes I want to find those 3 translations and needs to delete them from english language as well

October 5, 2018 at 5:50 pm #2791453

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi.

Ok, let's go through some steps and see if this will fix the issue.

❌ Please be sure to make a full backup of your site and database. ❌

Then, go to WPML -> Support -> Troubleshooting.

Look for 'Clean up' and click the following:
- Synchronize posts taxonomies
- Clear the cache in WPML
- Remove ghost entries from the translation tables
- Fix element_type collation
- Set language information
- Fix Terms count
- Fix post assignment for translations

Please let me know how this goes and if it solved your issue.

I will be waiting for your answer.