This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: I dont see the flags to be able to translate the pages

Solution: I would like to ask you to follow this steps: - Go to WPML -> Settings -> Post types translation -> Make sure that 'Pages' is set to be translatable. - Go to Pages -> Screen options (top right) -> Select the Language (flags) option.

Relevant Documentation:

This topic contains 3 replies, has 2 voices.

Last updated by Carlos Rojas 5 months, 1 week ago.

Assigned support staff: Carlos Rojas.

Author Posts
May 10, 2019 at 12:54 pm #3784373

gaetanL-3

I am trying to: Translate the site

Link to a page where the issue can be seen: I add to deactivate the english version for now it is not working hidden link

I expected to see: in the all pages of wordpress the is no flag for language

Instead, I got: a flag for french / english

I have uninstall and reinstall with and same result.

May 10, 2019 at 1:14 pm #3784781

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hello,
Thank you for contacting WPML support.

1.- I would like to ask you to follow this steps:
- Go to WPML -> Settings -> Post types translation -> Make sure that 'Pages' is set to be translatable.
- Go to Pages -> Screen options (top right) -> Select the Language (flags) option.

Could you tell me the result of the steps above?

2.- Please increase the PHP Memory Limit. Minimum requirements are 128Mb: https://wpml.org/home/minimum-requirements/
You can add this to wp-config.php to increase WP memory:

/** Memory Limit */
define('WP_MEMORY_LIMIT', '128M');
define( 'WP_MAX_MEMORY_LIMIT', '128M' );

- Add it above the line /* That's all, stop editing! Happy blogging. */

Kind regards,
Carlos

May 10, 2019 at 1:33 pm #3785033

gaetanL-3

My issue is resolved now. Thank you!

May 11, 2019 at 1:30 am #3788395

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,

I'm glad to hear that the issue is solved 🙂

Please don't hesitate to contact us if you need our help in the future with WPML. We will be more than happy to help.
Best regards,
Carlos