This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem:

I don't see the translation basked in WPML -> Translation Management.

Solution:

Please check if your user is set as a Translation Manager. WPML -> Translation Management -> Translation Roles.

Relevant Documentation:

https://wpml.org/documentation/translating-your-contents/

Tagged: 

This topic contains 10 replies, has 2 voices.

Last updated by Itamar 3 weeks ago.

Assigned support staff: Itamar.

Author Posts
September 19, 2019 at 7:08 pm

richS-3

I am trying to:

Translate Gravity Forms

I expected to see:

The Translation Basket Tab

Instead, I got:

The tab is missing

I sent along credentials to the site for you to have a look. The site protected via basic auth, however you can use the subdomain provided with the credentials for both the un/pw to access

September 22, 2019 at 3:27 pm #4618843

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi.

I couldn't see or connect to your site because I was not able to pass the basic auth. I've tried the credentials that you gave me for the WordPress admin, but they didn't work for me. Please edit the above private message and add the basic auth credentials.

But first please correct the following and see if it helps to solve the problem on your site.
By looking at the debug info that you have attached I can see that your server WP Memory Limit is set to 40M.
Our recommendations are to have the following as minimal requirements:
- PHP 5.6 and above (this OK with your installation) with a WP Memory Limit of at least 128MB and more if possible.
- MySQL 5.6 and above (this OK with your installation).
Please follow this link for detailed documentation:
https://wpml.org/home/minimum-requirements/
Is it possible for you to change those to the minimum requirement?
You may need to contact your hosting provider for that.
Meeting those baseline requirements is most critical before starting to debug and sometimes solves issues like you experiencing.
Most important is to raise the WP Memory Limit.
Please try to raise it before you contact your hosting company.
You can try and do it from the wp-config.php file in your WordPress installation.
Insert this code in that file.

/** Memory Limit */
define('WP_MEMORY_LIMIT', '256M');
define( 'WP_MAX_MEMORY_LIMIT', '256M' );

Add it before this line:
/* That's all, stop editing! Happy blogging. */

One other thing that I would like you to check is the following. Please go to Settings -> General and make sure that WordPress Address (URL) and Site Address (URL) are both set to either HTTP or HTTPS. Currently, it looks like there is a conflict, and they are not set the same.

Could you please perform that procedure and see if it help?

Thanks,
Itamar.

September 22, 2019 at 11:09 pm #4619575

richS-3

I gave those instruction in the last paragraph:

The site protected via basic auth, however you can use the subdomain provided with the credentials for both the un/pw to access..

I can't figure out how I can edit the private message, otherwise I would add it there. I can pass along via an email too if you pass one along -Rich

September 23, 2019 at 9:21 am #4621925

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi.

I've tried a few combinations to access the basic auth but failed. I'm enabling a private message for the next reply so you can share with me the correct basic auth.

Also, please let me know if you have tried my suggestion.

In addition, please try to see if the issue proceeds in a minimal environment.
I suspect that there is a collision with the theme or another plugin that might cause this problem. If possible, get your site into a minimum environment. Minimum environment means switching to a default WordPress theme like TwentyNineteen and no plugins activated except WPML. You will need first to check if the problem persists when just the theme is switched to TwentyNineteen (for example). If it persists then deactivate all plugins except the WPML and its add-ons. Then please check if the problem persists. If it does not persist, so start by activating the plugins one by one and check when the problem comes back, then report to me which was the culprit plugin.

**** Important! Please make a full site backup (files and DB) before you proceed with those steps****


*** If your site is a live site you might want first to try those procedures in a staging environment or a snapshot of your site on your local server or another server. ***

Thanks,
Itamar.

September 23, 2019 at 1:47 pm
September 23, 2019 at 3:54 pm #4625527

richS-3

Additionally, I cloned this site into another ENV and activated 2019, and deactivated all plugins with the exception of the WPML related plugins. The issue still exists: The "Translation Basket" does not appear on the Translation Management page, when I follow the instructions here:

https://wpml.org/documentation/related-projects/gravity-forms-multilingual/

- Rich

September 24, 2019 at 2:36 am #4627355

richS-3

I updated the memory via wp-config like you suggested.

September 24, 2019 at 9:17 am #4629563

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi and thanks for the access details.

The problem does not exist on your site now. The Translation Basket is there and I can see the Gravity Forms in it. And they are ready to be sent to translation. Please see the attached screenshot.
Can you see that it is OK now?

Regards,
Itamar.

September 24, 2019 at 2:44 pm #4632519

richS-3

Hey Itamar, for some reason i don't see this when i'm logged in as me, but I do see it when I'm logged in as you? Do I need to add my account to a specific role?

September 24, 2019 at 5:09 pm #4633169

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hey.

Please check if your user is set as a Translation Manager.
WPML -> Translation Management -> Translation Roles.

September 24, 2019 at 7:28 pm #4633893

richS-3

Yup that did it, thanks!

September 25, 2019 at 7:25 am #4636229

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Great, I'm glad that it is solved now!
Good luck with your web projects 🙂
Itamar.