This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 2 replies, has 2 voices.

Last updated by Mihai Apetrei 1 year ago.

Assigned support staff: Mihai Apetrei.

Author Posts
September 25, 2018 at 4:23 pm

taylorS-4

I am trying to: Translate an Astra custom layout (footer). I translated all the terms and the translation is completed on the back-end but it isn't reflected on the front-end.

Link to a page where the issue can be seen: hidden link

I expected to see: The footer translated to spanish

Instead, I got: The footer in english

September 26, 2018 at 6:56 am #2766067

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi and thank you for contacting WPML Support!

I will be very happy to help you with this.

I looked over your website's backend but I was not able to find the place where this footer area was created from. Can you please guide me through that and tell me where can I find it?

September 26, 2018 at 7:15 am #2766100

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi

I was able to find the footer in the "Custom Layouts" section.

It seems that while the English footer has the display rules set to "Display: Entire site" , the Spanish footer has no display rules set yet.

I will also attach 2 screenshots so that you can better understand what I mean.

I will need you to follow this steps:

1. Go to the Spanish backend
2. Go to Appearance > Custom Layouts
3. Click "Edit" on the "Custom Footer" page
4. Scroll down a bit till you get to the "Custom Layout Settings" section
5. From the "Display on" dropdown, select "Entire Site"
6. Scroll up and on the right click on the blue "Update" button.

If you will now go to the Spanish contact page (hidden link) you will be able to see the footer in Spanish, exactly as you created it.

Let me know if that worked for you, too.