Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 24 replies, has 2 voices.

Last updated by Riffaz 2 months ago.

Assigned support staff: Riffaz.

Author Posts
March 31, 2021 at 6:26 am #8436315

amyL-11

Add Plugins / Commercial shows only this:

No repositories defined.

I must point out that this is a multisite.

Screen Shot 2021-03-30 at 11.24.25 PM.jpg
March 31, 2021 at 6:32 am #8436347

amyL-11

This is a dev site, but it gets pushed to Production and I cannot have that error in production, where I will need to register the site.

March 31, 2021 at 7:25 am #8436785

Riffaz

1.
Have your registered your WPML using the main URL through the Network admin?
Updates are made only once through the network admin and affect all sites on the network.

2.
Have you checked your cURL issue with your hosting support?

3.
do you still see the toolset registration message?

4.
why can't you send all your replies in once rather than replying your own thread many times even before we reply to you?
take a breath. analyse. be calm. try the steps. then reply please.

Regards,

April 2, 2021 at 12:54 am #8451875

amyL-11

1. I see no way to register WPML through the Network Admin. But I have registered it through:

hidden link
( The master site. )

See attached for validation of registration for the 2 sites.

2. CURL is enabled on the 2 sites using WPML. I have checked with my host to validate this.

3. I still see the Toolset registration message. See attached.

( I have manually cleared the database of Installer Logs for both sites - there were way too many there. ) Now "Log is empty" and will not update upon multiple page loads.

Is this OK?

I have copy of the serialized data from the field stored locally

4. All replies are here.

Please advise - I do not want Toolset notices interfering with my WPML installation, when I have no need for it at all.

-Eddie

Screen Shot 2021-03-30 at 2.43.09 PM.jpg
Screen Shot 2021-04-01 at 5.18.42 PM.jpg
Screen Shot 2021-04-01 at 5.34.06 PM.jpg
Screen Shot 2021-04-01 at 5.19.58 PM.jpg
April 4, 2021 at 3:36 am #8461699

Riffaz

Hi,

Thank you for checking all.

I do not see such message here hidden link or anywhere on the site.

You are using older version of WPML Translation Management (attached screenshot)
Please update it and check.

The Toolset notification issue should just be solved when you register the WPML successfully as that helped for some other users.
Please refer:
1. https://wpml.org/forums/topic/message-saying-that-toolset-is-not-a-registered-version/
2. https://wpml.org/forums/topic/register-toolset-problem/

Are these same now in master and dev site?
I do not see any Toolset registration message anywhere on the site you provided to login and check.

( I have manually cleared the database of Installer Logs for both sites - there were way too many there. ) Now "Log is empty" and will not update upon multiple page loads.

Is this OK?
- this is fine

Screenshot_15.png
April 6, 2021 at 9:30 pm #8476721

amyL-11

I have registered the site successfully, as you can see in the screenshot.

And yet I still have the error. You can navigate there yourself with the credentials I provided:

hidden link

Please advise.

Screen Shot 2021-04-06 at 2.29.10 PM.jpg
Screen Shot 2021-04-06 at 2.23.48 PM.jpg
April 7, 2021 at 3:19 am #8478005

Riffaz

Hi,

Please check the attached screenshot.

Our system team needs to check this and they require
1. correct site login url
2. username
3. password

I am making the next reply private.

Regards,

Screenshot_22.png
April 7, 2021 at 4:35 am #8478449

Riffaz

Thanks for that.

we are checking this internally now.
I'll update you once we find the cause of this.

Regards,

April 9, 2021 at 6:36 pm #8504131

amyL-11

Please update me. Need to resolve this ASAP.

April 11, 2021 at 4:03 am #8508579

Riffaz

Hi,

Our developers are still checking this.
It's a but strange that never had happen like this with any other user. Particularly after all the suggestions worked for them.
Now our developers wants to test your database records and some PHP files.
That may lead your site down during the test.
So we require a copy of your site as explained here: https://wpml.org/faq/provide-supporters-copy-site/
Could you please provide one?

As a temporary workaround I added the following code to your functions.php
You can find it here: hidden link

add_action('admin_head', 'hide_toolset_connection_issue_notice'); // admin_head is a hook my_custom_fonts is a function we are adding it to the hook

function hide_toolset_connection_issue_notice() {
  echo '<style>
    .notice.otgs-installer-notice.otgs-installer-notice-toolset.otgs-installer-notice-connection-issues
{ display: none; }
  </style>';
}

Now there is no ant Toolset notification connection issue on your plugins page.
If this is ok you can go with this or please provide a site copy to dig this deeper.

Regards,

The topic ‘[Closed] I don't want Toolset’ is closed to new replies.