Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 9 replies, has 2 voices.

Last updated by Andreas W. 1 month, 3 weeks ago.

Assigned support staff: Andreas W..

Author Posts
July 16, 2021 at 10:27 pm #9219599

johnW-40

Tell us what you are trying to do?

I use Jetpack to share my posts to Twitter, Tumblr & Facebook. Unfortunately these English accounts are now being littered with translated posts! How do I prevent this? Is there a better way to share my posts, and if possible, divide them up by language?

Is there any documentation that you are following?

Is there a similar example that we can see?
See for instance my posts at hidden link
What is the link to your site?
hidden link

July 18, 2021 at 4:13 am #9223575

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

As far I see you refer to this Jetpack feature:
hidden link

The issue might be that when translating a post, also the Jetpack Publicize settings are copied and maybe there is a custom field that we could set to "not translate" in order to avoid this setting to be adjusted for post translations, but this would need to be tested.

https://wpml.org/documentation/getting-started-guide/translating-custom-fields/

For now I can only offer to have a look at the site and revise the configuration. If this will not solve the issue we might need to try to recreate this issue on a new test-site and take further steps from there.

The private reply form is enabled. Make sure to take a backup of website and database before providing access.

Best regards
Andreas

July 22, 2021 at 3:21 am #9249121

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

I can see that the posts inlcude two system custom fields:

_last_editor_used_jetpack
_publicize_twitter_user

Both are set to "not translate". Did you change their configuration in the meantime?

I am asking, as I want to make sure if those fields could have any influence on how WPML handles Jetpack's settings when translating a post.

I like to offer, that you could try to recreate this issue on a test-site which I could provide and from there I do some testing and escalate towards our compatibility team. Let me know if this would be possible?

In fact I believe that this might even requiere a new feature in WPML, like our WooCommerce Facebook settings at WPML -> Languages.

Our team is working hard on making Jetpack fully compatible and I am sure they would be glad if they can work a solution for this issue.

As an alternative I only see the following plufin on our compatilbity list, but as it is a premium plugin which I was not able to test yet, I can not confirm if is possible to achieve your goal with it:

https://wpml.org/plugin/social-auto-poster/

Best regards
Andreas

July 23, 2021 at 10:37 pm #9262887

johnW-40

Hi Andreas

I have made no modifications to custom fields.
So I guess those system fields are default custom fields - if that makes sense.
If you want me to test something, I will try. Let me know.
If you would prefer to test on another site, I will turn-off Jetpack sharing to social media, have a look at the suggested plugin, and weigh-up whether to go for that or just share manually.

July 23, 2021 at 10:41 pm #9262889

johnW-40

Looking at social-auto-poster, do you know how to make it post to different social accounts according to language? Is there a how-to?

July 24, 2021 at 2:25 am #9263701

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

I was looking for information about Social Auto Poster too, but I could not find more details. Sadly, I have no access to the plugin for a test.

I see there is a free version available:
https://wordpress.org/plugins/social-networks-auto-poster-facebook-twitter-g/

I have created a test-site here, so that we can do some testing:
hidden link

I have made a test here with Jetpack and actually I see now that Jetpack always asks for post options before publishing the post.

So in this case, I translated manaully, without the WPML Translation Editor and at the moment I save the translation on the WP Editor I can set the option to not to share this post.

Then I made another test with the WPML Translation Editor and here sadly we can not have any influence on the publication settings of Jetpack.
Anyhow, with the current default settings I can not replicate the issue as you can see here:

hidden link

My translate German post is not showing up on Twitter, not even when translated with the WPML Translation Editor.

Now, I also compared the custom field translation options to your site and I can not see any differencies here.

Can you confirm that the issue still persist on your site when publishing a bradn new post? If so, I might need to take a site copy for further testing, as the issue could be realted to a specific setting or even another active plugin.

Best regards
Andreas

July 24, 2021 at 2:43 am #9263811

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

I am sorry for the confusion, but there seems was a kind of longer delay on Twitter. I can see now the German post after translating with the WPML Translation Editor.

Further, I can actually see the German post content, while the actual post link is actually pointing on both tweets to the original EN post.

So, at this point I have escalated the issue towards our compatilbity team.

I will contact you as soon I received more feedback from our team.

Best regards
Andreas

July 24, 2021 at 9:33 pm #9265637

johnW-40

I am glad it is not something that I have done wrong on my site and hope to hear back about any solution. Meanwhile I will turn-off Jetpack sharing and investigate the recommended plug-in. Thank you.

July 24, 2021 at 9:35 pm #9265639

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Thank you for your message.

Once I have more feedback from our team regarding this issue I will be in contact.

Do not hesitate to contact me or open a new ticket if you have questions regarding the alternate plugin suggestion.

Best regards
Andreas

July 28, 2021 at 10:30 am #9298043

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

I am writing to you to let you know that my colleague Andres has found a workaround for the issue that could get applied in the meantime.

1) Create a post
2) Duplicate the post with WPML
3) Mark the duplicate to be independent
4) Translate the post with ATE

The procedure is explained in detail here:
https://wpml.org/documentation/translating-your-contents/displaying-untranslated-content-on-pages-in-secondary-languages/

I hope this can help you in the meantime, until our team has founda fix for the issue. It worked asepxected on my test-site.

See latest post "Test Andres 28th July" here:
hidden link

Best regards
Andreas