This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 6 replies, has 2 voices.

Last updated by Bigul 6 months, 1 week ago.

Assigned support staff: Bigul.

Author Posts
April 16, 2019 at 10:38 am #3621015

sameri-3

the problem is when i switch the language, i get the 404 error page

Link to a page where the issue can be seen: hidden link

It was working fine a few days ago, then suddenly this issue appear. I contacted the hosting website and they told me, it is WPML issue.

I deleted the plugins & installed them again, same problem.

April 16, 2019 at 6:17 pm #3624619

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Welcome to the WPML support forum. I will do my best to help you to resolve these issues.

Please visit WPML>>Languages and check you are getting any warning in *Language URL format* section now.

Also please share with me the WordPress debug.log (not WPML debug information) for tracking the issue. Please check this page for instructions https://wpml.org/documentation/support/debugging-wpml/

To enable it, open your wp-config.php file and look for define(‘WP_DEBUG’, false);. Change it to:

// Enable WP_DEBUG mode
define( 'WP_DEBUG', true );
 
// Enable Debug logging to the /wp-content/debug.log file
define( 'WP_DEBUG_LOG', true );
 
// Disable display of errors and warnings 
define( 'WP_DEBUG_DISPLAY', false );
@ini_set( 'display_errors', 0 );

// Use dev versions of core JS and CSS files (only needed if you are modifying these core files)
define( 'SCRIPT_DEBUG', true );

In this case, the errors will be saved to a debug.log log file inside the */wp-content/* directory. Please do the steps to reproduce the bug and check you are getting any errors or warning related to WPML in the log file.

If you can paste your debug.log to http://pastebin.com/index.php and provide me that link it would be great! (This is the cleanest way because sometimes the logs are long and create a complete mess of discussion).

--
Thanks!

Bigul

April 17, 2019 at 8:03 am #3628217

sameri-3

https://pastebin.com/bUs1hJv3

hope this is what you asked for.

April 17, 2019 at 8:57 am #3628851

sameri-3

Hello Bigul,

Just to let you updated, i tried few things on WPML and the 404 page gone, but still can't switch the language, the default language is English & it remains English when i switch the language.

please take a look.

Thanks

April 17, 2019 at 12:41 pm #3630795

sameri-3

Herre is the error_log

https://pastebin.com/8eKBSRm2

April 17, 2019 at 12:47 pm #3630819

sameri-3

Hi Bigul ,

Now i see : (Error: Cookie nonce is invalid) under Advanced Translation Editor is enabled and active

in WPML setting

April 17, 2019 at 1:16 pm #3631111

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the details. The Debug log is showing the following error a few times. But it is an old log and the recent log(from April) is not showing any error related to WPML.

[12-Feb-2019 18:23:00 UTC] PHP Fatal error:  Out of memory (allocated 128712704) (tried to allocate 8192 bytes) in /home1/samerhajissa/public_html/wp-content/plugins/sitepress-multilingual-cms/vendor/composer/ClassLoader.php on line 444

[12-Feb-2019 18:23:00 UTC] PHP Fatal error:  Unknown: Cannot use output buffering in output buffering display handlers in Unknown on line 0

Therefore I have a request. Please upgrade the following configuration for the expected performance of your site and check the issues are existing or not.

1) Increase *WP Memory Limit* to *256*(the minimum required memory limit for WPML is *128*). Please check the following links for more details

https://wpml.org/home/minimum-requirements/

https://codex.wordpress.org/Editing_wp-config.php#Increasing_memory_allocated_to_PHP

2) Increase the *MaxInputVars* of PHP settings to *10000*. Please check the following article for more details or contact your system admin/hosting provider for this purpose.

hidden link

--
Thanks!

Bigul

The topic ‘[Closed] I get 404 error page when i switch the language’ is closed to new replies.