This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 1 reply, has 2 voices.

Last updated by Alejandro 3 months, 2 weeks ago.

Assigned support staff: Alejandro.

Author Posts
July 3, 2019 at 6:26 am

cyrusB

I am trying to: see my translations

Link to a page where the issue can be seen:
hidden link

I expected to see:
the English version of my site
Instead, I got:
404 error.
I have done. everything from the support section as to re install the plugins and the troubleshooting from the support page, but it won't work. -my memory is really high, so it can't be a memory issue

July 3, 2019 at 6:46 am #4132381

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Hello!
Welcome to WPML Support.
I'll do my best to help you solve this issue.

There was a warning in your apge saying that since you were using the traditional permalink structure, you wouldn't have been able to translate slugs which is something you needed in order tu run your site's configuration.

I changed the permalink structure in Settings > permalinks and that seems to have fixed everything.

Can you please confirm that everything's ok on your end as well? i tried changing from german to English through the language switcher and it worked without issues.

Let me know how it goes.