This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 16 replies, has 2 voices.

Last updated by Bigul 4 months ago.

Assigned support staff: Bigul.

Author Posts
May 16, 2019 at 11:43 am #3825585

Richard

I am trying to:
finish the setup for:
In order to get WPML Media Translation fully working, you need to run this set up which takes only a few moments depending on the total number of posts in your WordPress install.

Link to a page where the issue can be seen:
WPML -> setup required

I expected to see: OK

Instead, I got: Service is unavailable

May 16, 2019 at 3:43 pm #3827691

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Welcome to the WPML support forum. I will do my best to help you to resolve these issues.

Please share with me the WordPress debug.log (not WPML debug information) for tracking the issue. Please check this page for instructions https://wpml.org/documentation/support/debugging-wpml/

To enable it, open your wp-config.php file and look for define(‘WP_DEBUG’, false);. Change it to:

// Enable WP_DEBUG mode
define( 'WP_DEBUG', true );
 
// Enable Debug logging to the /wp-content/debug.log file
define( 'WP_DEBUG_LOG', true );
 
// Disable display of errors and warnings 
define( 'WP_DEBUG_DISPLAY', false );
@ini_set( 'display_errors', 0 );

// Use dev versions of core JS and CSS files (only needed if you are modifying these core files)
define( 'SCRIPT_DEBUG', true );

In this case, the errors will be saved to a debug.log log file inside the */wp-content/* directory. Please do the steps to reproduce the bug and check you are getting any errors or warning related to WPML in the log file.

If you can paste your debug.log to http://pastebin.com/index.php and provide me that link it would be great! (This is the cleanest way because sometimes the logs are long and create a complete mess of discussion).

--
Thanks!

Bigul

May 17, 2019 at 8:01 am #3831949

Richard

Hi Bigul,

Thanks for the fast responce!

I did exactly what you asked but....
so changed the values in wp-config file for debugging.

When I then tried to finish the setup agian nothing happens.
There is rotating icon next to the finish setup button that just keeps on turning.
There is no debug.log file generated in the wp-content folder !?
So where a bit stuck here 😉
I could give you a admin login if thats any usefull?

Regards Richard

May 17, 2019 at 12:23 pm #3834375

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Richard,

Thank you for the feedback. Please try it after the following steps and make sure the issue is existing or not.

a) Please increase the *MaxInputVars* of PHP settings to *5000* or more. Check the following article for more details or contact your system admin/hosting provider for this purpose.

hidden link

b) Visit WPML>>Languages>>Make themes work multilingual, enable *Adjust IDs for multilingual functionality* option

c) Visit WPML>>Languages>>Language filtering for AJAX operations, enable *Store a language cookie to support language filtering for AJAX* option

If the issue exists, maybe you are facing this issue because of compatibility conflicts. So to make sure if possible, please do the following steps.

a) Backup your site first
b) Switch for a moment to a WordPress default theme like 2017
c) Deactivate all the plugins that are not related to WPML
d) If the issue is gone, activate the plugin one by one to see with which one there is an interaction issue

--
Thanks!

Bigul

May 17, 2019 at 1:41 pm #3834901

Richard

A.
Okay where do i put the custom code?
because I have tried all options but when ever I add your sugested code to this file my site stops working.

This is whats in the htaccess file now:

# BEGIN WordPress
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]
</IfModule>

# END WordPress

php_value max_input_vars 5000

I have allready added a test.php file with

<?php phpinfo(); ?>

in it, so you can see the php settings as they are now.

B. and C.
Done

D.
No result when changing themes and disabling all plugins but WPML. and trying again.
Same problem persist.

So this is very strange... whats

May 17, 2019 at 6:40 pm #3836549

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Richard,

Thank you for the updates. Please check you are getting any error in the Server error log(Apache) while having this issue.

Please fill the private details fields after a full site backup. I would like to access the admin area of your site for further checking.

Please check the following links for more details about our private information sharing policies.

https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

hidden link

--
Thanks!

Bigul

May 20, 2019 at 8:47 am #3844969

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Richard,

Thank you for the login information. This may be happening because of the compatibility conflicts with the server. The browser console is showing a JavaScript error.

But I was able to sync the Media files from WPML>>Settings>>Media Translation. Therefore please check you are getting any error in the Server error log(Apache) while having this issue.

Please check the attached images for more details.

--
Thanks!

Bigul

May 23, 2019 at 1:49 pm #3875965

Richard

Hi Bigul,

I can not see the apache error log file. I don't have acces to this.

And this other error does not say anything to me either.
Is there no other way to get this sorted?

The service unavailable message still remains in my admin area.

Regards,
Richard

May 23, 2019 at 6:28 pm #3878757

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Richard,

Thank you for the updates. Please allow me to make a duplicator copy of your site using the Duplicator plugin(https://wordpress.org/plugins/duplicator/) for debugging the issue on my local server.

--
Thanks!

Bigul

May 27, 2019 at 7:35 am #3894103

Richard

Hi Bigul,

Sure you can go ahead.
You can use the admin account that I have provided ealier for that.

Regards,
Richard

May 27, 2019 at 5:54 pm #3900139

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Richard,

Thank you for your permission. I made a Duplicator copy of the site now. Will debug it further and get back to you soon. Please wait.

--
Thanks!

Bigul

May 28, 2019 at 9:38 am #3904861

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Richard,

For your kind updates, it is working fine in my local servers. Therefore I have forwarded the details to our second tier team for the expert opinion. We will get back to you soon. Please wait.

--
Thanks!

Bigul

May 31, 2019 at 2:13 pm #3931169

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Richard,

For your kind updates, we are not able to reproduce the issue on our servers. It works as expected. Please check the following Video URL.

hidden link

This may be happening because of the server low resources or security settings. So can you please check the following.

a) Please enabled Debug mode and check is there any error is tracked in the *wp-content/debug.log* file

b) Please check with your hosting team that you are getting any error in the Server error log(Apache) while having this issue

Please note, I am not able to login to the FTP now. It shows the following error.


Response: 220 You will be disconnected after 15 minutes of inactivity.
Command: USER *****
Response: 331 User **** OK. Password required
Command: PASS **********
Response: 530 Login authentication failed
Error: Critical error: Could not connect to server

--
Thanks!

Bigul

June 11, 2019 at 1:09 pm #3995527

Richard

Hi Bigul,

Thanks again for your updates regarding this issue.
I allready tried the debug mode option and thath did not work.
like I said on may 17th :
"There is no debug.log file generated in the wp-content folder !?

Ï was just thinking...
What actually happens when you click the button behind the scenes?
Will this do anything to any table in the database?
If so can you not just send me the correct table for the database so I bypass this whole setup process?
This is a one time proccess right?

I will contact the hosting team for the other option you mentiond.

June 11, 2019 at 6:13 pm #3997975

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Richard,

Thank you for the updates. This action will duplicate the media files to the secondary language. There will not be physical duplication of media files but will create an extra entry for each media file in the database for making it available in the secondary languages. So it will be using the same database tables. Please check the following documentation for more details.

https://wpml.org/documentation/getting-started-guide/media-translation/

Please try the following troubleshooting steps after a site backup and make sure the issue is existing or not.

1) Go to WPML>>Support page

2) Click on Troubleshooting link (blue link in the middle of the page)

3) In Troubleshooting page, please click on the following options of the *Clean up* section. Wait for confirmation of processing after each one.

- Clear the cache in WPML
- Remove ghost entries from the translation tables
- Fix element_type collation
- Set language information
- Fix WPML tables collation

4) Then check you can finish the Media setup or not

--
Thanks!

Bigul

The topic ‘[Closed] I get a message"Service is unavailable" when I click "Finish Setup"’ is closed to new replies.