This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 11 replies, has 2 voices.

Last updated by Andreas W. 4 months, 3 weeks ago.

Assigned support staff: Andreas W..

Author Posts
May 23, 2019 at 7:52 pm #3879241

marcH-33

I am a new user trying to set up WPML and I experience troubles.

When I click the "Learn more" button, as well as the "Media Translation documentation" link under the heading "Learn how to translate media", I get the following error:

Forbidden
You don't have permission to access

/wp-admin/index.php

on this server.

I also get this error when I click the "Enable it now" button under the heading "One more step before you can translate on Divi".

Furthermore, as a Divi user I have tried to follow the instruction to go to the WPML -> Translation Management page and click on the Multilingual Content Setup tab. But this Multilingual Content Setup tab is absent on that page...

Permissions:
wp-admin/index.php 0644
wp-admin/ 0755

Please assist.
(I have a meeting with a client tomorrow where I should be able to show something about WPML...)

May 23, 2019 at 10:17 pm #3879683

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Thank you for contacting WPML Support.

I am not sure why the notification buttons and links are not working as supposed on your site but you can find the Media Translation documentation here:

https://wpml.org/documentation/getting-started-guide/media-translation/

The WPML Classic Translation Editor or our Advanced Translation Editor can enabled at WPML -> Settings -> How to translate posts and pages. We advise to do this always when it comes to working with page builders.

Choose your prefered moedl and activate it before starting to translate. Also please avaoid to change the Editor once you have created translations.
https://wpml.org/documentation/translating-your-contents/advanced-translation-editor/
https://wpml.org/documentation/translating-your-contents/using-the-translation-editor/

The Multimedia Content Setup is now located at WPML -> Settings. Further, each post, page or custom post type includes a multilingual content setup section at the bottom of the WordPress Editor page, in which you can select settings for the relevant custom fields for the repsective content.

I hope this answered your questions. Let me know if you need further assistance.

Kind regards
Andreas

May 26, 2019 at 12:51 am #3890323

marcH-33

Hello Andreas,

Thank you for the assistance.

A problem that remains is that as long as the links of the "Learn how to translate media" message produce an error ("Forbidden. You don't have permission to access… etc."), there is an overlay on the Translation Dashboard page of the Translation Management.
The "Learn how to translate media" message also continues to appear on top of all the admin pages of the site.
I am not able to close the message.
I have postponed with a few days the session with the client where I will have to demonstrate the working of WPLM.
If this issue is not resolved by then, that won't look good.

Is there a hack to get rid of the message?
The troublesome URL is hidden link

Sincerely,
Marc

May 26, 2019 at 1:09 am #3890347

marcH-33

Hello Andreas,

I just installed the latest update of the Divi theme and I noticed that the wpml-config.xml got overwritten. Is that normal? I had previously downloaded the same file from the WPML repository.

Sincerely,
Marc

May 26, 2019 at 11:32 pm #3892513

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Indeed, the language config files are receiving updates through theme updates. Our compatibility team is working permanently on keeping those files updated and include the latest theme or plugin features. In some cases theem author´s implement new features. Those features can get accessed thorugh WPML but sometimes it is necessary to use a custom XML config.

https://wpml.org/documentation/support/language-configuration-files/

About the admin notifications it appears weird to me that you are not able to close thema nd that the links are not responding.
Can you please try accessing your database and in the wp_options table, look for a field named 'wpml_notices' or 'icl_admin_messages'. Inside the value field you should be able to see the messages. Simply delete them, and after you refresh your dashboard, let me know if the messages appear again.

Let me know if you need any further assistance or if you got any open questions.

Kind regards
Andreas

May 31, 2019 at 5:12 pm #3932341

marcH-33

Hello,

After disabling my security plugin I have discovered that this was the reason why I got the "Forbidden You don't have permission to access /wp-admin/index.php on this server" error.
review the Media Translation documentation.
I was now able to click the "Learn more" button, as well as the "Media Translation documentation" link under the heading "Learn how to translate media", and to get to the page on the wpml.org website (https://wpml.org/documentation/getting-started-guide/media-translation/), which I had already read by the way.

BUT THE BANNER REFUSES TO DISAPPEAR!!

That is extremely annoying because it literally appears EVERYWHERE on the admin pages, also of all the other plugins!

Can you please assist so this disappears?!

May 31, 2019 at 5:35 pm #3932479

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

I am sorry to hear that you experience this inconvenience. Usually the notification should show an X in the right upper corner. Did you try to click the notification and then verify of you are able to close it afterwards, once it has been clicked once?

Further, as mentioned earlier it is possible to delete such messages directly inside the wp_options table but please make sure to take a databse backup before making any changes.

The notiification messages my appear in the the key value fields named 'wpml_notices' or 'icl_admin_messages'.

If you need any assistance for this task please provde access to your site and FTP and/or provide us access to your PHPmyAdmin.

Your next message is set to private in order to provide credentials.

Kind regards
Andreas
Scroll the value fileds to locate the message and delete it. After you refresh your dashboard, let me know if the message reappears.

Kind regards
Andreas

May 31, 2019 at 6:06 pm #3932611

marcH-33

Yes, afterwards there is an X afterwards. When clicked the notification disappears, only to appear again when opening another page.
With regards to the key value fields named 'wpml_notices' or 'icl_admin_messages', I don't find these.

May 31, 2019 at 6:11 pm #3932635

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

the wp_options table can contain a bigger amount of pages. Did you try to set the limit of shown items to 500 and to search through the pages?
Try to use the broser search field (Ctrl + F on Windows - Command + F on Mac)

If you could provide access to PHPmyAdmin or in case you got the Adminer Plugin installed I can offer you to take a look myself?

Kind regards
Andreas

May 31, 2019 at 8:51 pm #3933167

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Thank you for providing access.

I have applied the changes to the respective vlaues inside of the wp_options table.

Please log into your wp-admin and let me know if the notifications have disappeared.

Kind regards
Andreas

May 31, 2019 at 9:12 pm #3933311

marcH-33

No luck.

May 31, 2019 at 9:49 pm #3933495

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

I would like to request temporary access (wp-admin and FTP) to your site to take a better look at the issue. It would be better to a testing site where the issue is replicated.

You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Maybe I'll need to replicate your site locally. For this, I’ll need to temporarily install a plugin called “Duplicator” on your site. This will allow me to create a copy of your site and your content. Once the problem is resolved I will delete the local site. Let me know if this is ok with you.

IMPORTANT

Please make a backup of site files and database before providing us access.
If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this:
hidden link

Kind regards
Andreas

The topic ‘[Closed] I get error messages during setup’ is closed to new replies.