This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 1 reply, has 2 voices.

Last updated by Riffaz 1 year ago.

Assigned support staff: Riffaz.

Author Posts
October 11, 2018 at 6:04 pm

malikK

I am trying to: NOT SEEING THE WARNING MESSAGES

Link to a page where the issue can be seen: hidden link

I expected to see: NOT SEEING THESE WARNING MESSAGES

Instead, I got: THESE WARNING MESSAGES

October 12, 2018 at 6:53 am #2810921

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi Malik,

You are using an older version of WPML.
please update it to the latest version and check.

If that does not help:
Warnings and Notices in WordPress will not cause the site's function to halt at any time, therefore, they do not pose a threat to the way your site or plugins are functioning.

There is most likely a small incompatibility between WPML and your theme or a 3rd party plugin which is not significant enough to cause problems to the way your site is running.

you can safely remove these warning by doing the following

Go in your

wp-config.php

file and look for

define('WP_DEBUG', true);

Change it to:

define('WP_DEBUG', false);

If you are still having the issues, maybe you are facing this issue because of compatibility conflicts. So to make sure if possible, please do the following steps.

a) Backup your site first
b) Switch for a moment to a WordPress default theme like Twenty Seventeen
c) Deactivate all the plugins that are not related to WPML
d) If the issue is gone, activate the plugin one by one to see with which one there is an interaction issue.

or within your wp-config.php file please replace

define('WP_DEBUG', false);

with

ini_set('display_errors','Off');
ini_set('error_reporting', E_ALL );
define('WP_DEBUG', false);
define('WP_DEBUG_DISPLAY', false);

[These don’t affect your site in any way.]

this may happen most likely because your host server was forcing the display of notices and warnings.

Hope, this will help you.

Regards,
Riffaz.

The topic ‘[Closed] I got this –> "Warning: Cannot assign an empty string to a string offset in.."’ is closed to new replies.