Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 8 replies, has 3 voices.

Last updated by Yvette 1 year, 6 months ago.

Assigned support staff: Yvette.

Author Posts
November 20, 2019 at 6:32 pm #4983331

francescoM-34

I am trying to: UPDATE WPML plugins

in the area plugins<add new<commercial<
The warning I see is: hidden link

I have always problems in updating the plugin mainly when it's along with WooCommerce Multilingual.
When I update all of the elements to be updated from the WordPress admin area it happens:
1- the home page/it redirection in English links to the cart (wrong redirection)
2- the shop/en is in Italian instead of English.
I use the site in staging to make the updates.
The site online at the moment is safe.

Do you suggest me to remove all plugins, make the download, and add them new?
Would this procedure affect the translations or the good functioning of the site in some way?

November 20, 2019 at 8:46 pm #4984087

Pierre
Supporter

Languages: English (English ) French (Français ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hello,

The warning that you reported "PHP Warning: Declaration of Installer_Upgrader_Skins::feedback" is a known issue and it's fixed in our lastest version.

If you don't manage to update your plugins automatically, could you try the manual way? See the recommended steps in https://wpml.org/faq/install-wpml/.

Thanks,
Pierre

November 21, 2019 at 11:49 am #4987457

francescoM-34

Hi Pierrre,
you mean I should remove the plugins and dowload the fresh ones and re-add them? This is what you mean for update manually? And if so, would it be a problem for an exhisting website (two years)? Just to know before doing anything. Grazie, Ciao Raffaella

November 21, 2019 at 12:46 pm #4988101

Pierre
Supporter

Languages: English (English ) French (Français ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hello Raffaella,

> you mean I should remove the plugins and dowload the fresh ones and re-add them? This is what you mean for update manually?

Yes, this is what I mean.

> And if so, would it be a problem for an exhisting website (two years)?

You current WPML version is not too old so it should not be a problem to update now. If you feel uncomfortable with this, maybe you can take a copy of your current site with the Duplicator plugin (you might feel safer).

Thanks,
Pierre

November 21, 2019 at 3:23 pm #4990035

francescoM-34

Ciao Pierre.

Thanks for your reply.
I did the download of WpMl plugins.
While canceling I added them all again one by one.
Now I see this notice: hidden link
I have the key to the site. But do not know if this has something to do with the notice. If so, how can I add it? Or what should I do to have all set perfectly?
By the way, I work on the staging part of the online site.

Thank for your help.

Raffaella

November 21, 2019 at 3:32 pm #4990161

Pierre
Supporter

Languages: English (English ) French (Français ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Raffaella,

>Now I see this notice: hidden link

By default the REST API should be enabled on WordPress sites (see also https://wpml.org/documentation/support/rest-api-dependencies/). You need to find out why this is disabled.

It could also be a false positive. If you can edit and save a post with the WordPress default block editor, this will confirm that the REST API is working as expected.

>I have the key to the site. But do not know if this has something to do with the notice. If so, how can I add it? Or what should I do to have all set perfectly?

You can add the site key in Plugins > Add new > Commercial tab (please see this FAQ https://wpml.org/faq/install-wpml/#faq).

Thanks,
Pierre

November 22, 2019 at 10:28 am #4996027

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Rome (GMT+02:00)

Hello

I will be helping you now as Pierre is no longer available.

Can you please reply to his remarks on his last message to you?

November 22, 2019 at 6:34 pm #5001407

francescoM-34

Good afternoon Yvette, I removed all wpml plugins and re-added again. There was a problem in opening the website, but the hosting (siteground) solved me this problem. Thank you for getting in touch. Wish you a nice evening. Raffaella

November 24, 2019 at 7:34 pm #5007505

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Rome (GMT+02:00)

Ok - does this mean that the original issue has been resolved?