Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 8 replies, has 2 voices.

Last updated by Dat Hoang 5 years, 5 months ago.

Assigned support staff: Dat Hoang.

Author Posts
April 23, 2015 at 2:10 pm #604898

ireneL-3

I am trying to: fix this problem to not happena again. At the moment as my website is online I redirect 404 error to the right url but this shouldn't be the solution

URL of (my) website where problem appears: hidden link

I expected to see: hidden link

Instead, I got: hidden link

April 24, 2015 at 7:20 am #605309

Dat Hoang

Your WPML versions are up-to-date.

I've just checked your site at hidden link . When I click at a portfolio, e.g: hidden link , I'm redirected to hidden link

That looks correct with your need above.

Have you resolved the problem by yourself?

April 24, 2015 at 7:38 am #605327

ireneL-3

Hi,

no I didn't resolve it in a proper way.. I just installed a redirection plugin error 404 because I cannot keep my site online with that error. I need to disable the plugin to let you see the error or you could see it anyway looking at the code?

PLease let me know, if you are looking at it now and I need to disabled it I'll do it as I don't want the web online long time with that error...

I will constantly add new portfolio and it's second time this pass, so it would be much better to have a proper solution.

Your colleage Ross f. had a look at this problema but it wasn't solved as to fix it I deleted the previous single portfolios and created them again. Cannot think to do like this everytime of course!
it was working properly but the only other thing I did was to sync the menus (with the WP Menu Sync plugin of WPML) to resolve another URL problem I got with the menu translation.. (as I translated more strings) I resolved that problem but I got this other one!!!

waiting to know when you'll have a look at it and if you need I disabled the redirection plugin

thanks and regards

April 24, 2015 at 10:04 am #605479

Dat Hoang

#1,
OK. Could you please create a testing site and let me take a look?
That's much better than giving a live site.

I need to request temporary access (wp-admin and FTP) to your site in order to be of better help. You will find the needed fields for this below the comment area when you log in to leave your next reply. hidden link

These info is private, and available to you and supporters only.

Note that:
+ Backup (both files and database) your site before giving us your credentials
+ It would be better if you give me the test site rather than the live site.

#2,
The theme Jkreativ is currently not in our WPML Theme Compatibility list: https://wpml.org/documentation/theme-compatibility/ so this might be a compatibility problem.

And I understand that the theme is creating the post type 'portfolio'? If so, please give me a copy of site and let me test. Please upload the theme somewhere and give me the link to download.

#3,
You were working with Ross - our supporter. Could you give me the link and let me take a look there?

May 6, 2015 at 9:13 am #612942

Dat Hoang

Thanks for your all info.

Please go to WPML > Translation Management > Multilingual Content Setup > Custom posts > Portfolio > Select "Use different slugs in different languages for Portfolio." and set all of them are: 'portfolio'.

Before these was:
+ Italian: itportfolio
+ Spanish: spportfolio

After saving it, the links are correct now. Could you check your site and confirm that?

May 6, 2015 at 9:26 am #612956

Dat Hoang

Sorry... this does not help.
The Spanish portfolio links are "Not found" now.

I'm looking into it and getting back to you soon.

May 6, 2015 at 9:48 am #612989

Dat Hoang

Actually I can not find the reason and the way to give you a temporary workaround.

This is really a compatible problem when it looks like in the register_post_type function, the theme author is using the parameter 'rewrite' without the value 'portfolio' - the same with post_type.

(The file jkreativ-themes\admin\post_type.php), line 70

	 	'rewrite' 				=> array('slug' => '%portfolio_page%','with_front'=>true),

This option should be 'rewrite' => true

We wrote about this specific case at https://wpml.org/documentation/getting-started-guide/translating-page-slugs/ (in the bottom) and https://wpml.org/faq/how-to-translate-custom-types/

Actually it's not simple like editing a line because the theme author is using a lot of filters for this.

-----
I suggest contacting with the theme author and ask them apply to our Go Global program: http://wpml.org/documentation/theme-compatibility/go-global-program/ .

The theme author can announce anything but we can make sure and test with the themes that are listed under our lists only.

May 6, 2015 at 10:12 am #613017

ireneL-3

Many thanks Dat for your help.
I will contact immediately with the theme support translating your message.

I think they should take care with a matter of urgency about this as they declare that is compatible with WPML!

Let you know
thanks and regards

May 7, 2015 at 5:14 am #613694

Dat Hoang

Thanks for your info.
Please update me when having any info.

And if possible, ask the theme author to join our Go Global program, then he can work with our compatibility team directly. That's much better rather than giving the support here. Because the supporters can just diagnose the problems.

Thanks for your patience.

The topic ‘[Closed] I have again the same problem with URL in portfolio single product URGENT!!’ is closed to new replies.